We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PDF to TIFF rendering - parallel processing does not work

We tried to implement a multithred converter from PDF to TIFF but it seems that the parallel processing with multiple threads does not work correct.

See the exception stack trace which is fired when rendering a Pdf document on a TiffDevice.

at System.IntPtr.ToInt32()
at e.‚.(Bitmap )
at e.‚.(Bitmap , Int32 , Int32 )
at e.‚.(Bitmap )
at Aspose.Pdf.Devices.TiffDevice.Process(Document document, Int32 fromPage, Int32 toPage, Stream output)
at Aspose.Pdf.Devices.DocumentDevice.Process(Document document, Stream output)
at Aspose.Pdf.Devices.DocumentDevice.Process(Document document, String outputFileName)

Hi WMay,

Thanks for using our products. I tried to test your issue but unable to replicate the scenario at my end. However, to exactly replicate your issue at our end, we would appreciate, if you create a sample application and post here to show us the issue with template PDF documents you are using. This will help us to regenerate the issue and get the cause of the issue soon.

We apologize for your inconvenience.

Thanks & Regards,