We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PdfFileEditor.Concatenate file size 0 works with PdfFileEditor.ConcatenateForms

Hi,


I have a strange problem with the concatenate method in PdfFileEditor. It works perfectly fine when I run it on my local computer, but when I run the same code and using the same files (copied - both places I access them on a local drive and both places I’ve use several different files and they all fail) on our web server I get a stream of size 0 after calling the concatenate method. I tried using both streams and streams as parameters but the result is always the same: a stream/file of size 0. So I thought I would give the deprecated method ConcatenateForms at try - and who would have though this…it actually works!

On my local machine I run a 64 bit version of windows 7 and on the webserver we have windows server 2008 64-bit installed. Both places I use version 4.8.00 of aspose.pdf.kit

Any good ideas about why this is so?

Hi Bjarke,

First of all, I would like to share that ConcatenateForms method is now obsolete, so it is better that you use the Concatenate method for future. However, if you’re having any problems using this method, we’ll try to provide you a fix for that.

Secondly, please try to download the latest version (4.9.0) and test it at your end with Concatenate method. If it still doesn’t resolve your issue then please share a small sample application along with the input PDF files which can help us reproduce the issue at our end.

We’re sorry for the inconvenience and looking forward to help you out.
Regards,