We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Pop3Client Login Problem

Hi,

I´m testing the Aspose.Network.Pop3 Namespace in my application and I´m having a problem in login. I´ve tried this:

Pop3Client client = new Pop3Client(“mydomain”, 110, “myemail”, “mypass”);
client.EnableSsl = false;
client.Connect(false);
client.Login();

The Mail Server is installed locally in my machine, so, no network problem should be happening. When I test my Mail Server with telnet, using the authentication informations that I´m passing to pop3client object, all works fine.

The message of exception is “Login error-ERR Invalid user name or password.”.

Ps.: I also have tried using Connect(true) without calling Login(), and Login(Pop3Authentication authentication) with all authentication types.

Can anyone help me???

Sorry for my poor English.

Regards,

Ronney

Hi Ronney,


Thanks for considering Aspose.

Could you please try by giving the IP address of your local machine in the Pop3Client class as follows and check if it works?

Pop3Client client = new Pop3Client(“192.168.1.10”, 110, “myemail”, “mypass”);
client.Connect(true);

Hi Saqib,

I´ve already tried this, and still not working. I think it´s not a problem with the address, because I´m receiving a login error from my mail server. I´ve looked the log file in my mail server and the messages looks like this:

“POP3D” 4172 44 “2010-06-18 15:57:15.612” “127.0.0.1” "SENT: +OK POP3"
“POP3D” 8144 44 “2010-06-18 15:57:15.626” “127.0.0.1” “RECEIVED: CAPA”
“POP3D” 8144 44 “2010-06-18 15:57:15.630” “127.0.0.1” “SENT: -ERR Invalid command in current state.”
“POP3D” 8036 44 “2010-06-18 15:57:16.233” “127.0.0.1” “RECEIVED: USER ***”
“POP3D” 8036 44 “2010-06-18 15:57:16.236” “127.0.0.1” “SENT: +OK Send your password”
“POP3D” 7304 44 “2010-06-18 15:57:16.241” “127.0.0.1” “RECEIVED: PASS ***”
“POP3D” 7304 44 “2010-06-18 15:57:16.253” “127.0.0.1” "SENT: -ERR Invalid user name or password."

I point out that when I´m testing the connection with telnet, everything works fine.

Grateful,

Ronney

Hi,

I ran a sniffer in my network card while my application was trying to login into my mail server, and I´ve got a possible bug in Aspose.Network.Pop3.Pop3Client. In the result of sniffer, both the username as the password were the same, but, in my code, I´m passing different ones.

Can anyone verify this?

Thanks,

Ronney

Hi Ronney,


Could you please give only the username part (excluding the domain name) in the Pop3Client’s constructor as follows and see if it works?

Pop3Client client = new Pop3Client(“127.0.0.1”, 110, “user.name”, “pwd”);

Hi,

See if
you know what I mean:
no matter what I give for Pop3Client.UserName or Pop3Client.PassWord. The request to my mail server is always:

--------------------------------------------------------------------
USER [username]
PASS [username] <— wrong
--------------------------------------------------------------------

Ps.: Consider [username] the content of Pop3Client.UserName.

The Aspose is passing [username] instead of [password] to my mail server.

I gave up using Aspose, but it would be nice if you fix this bug.

Thankful,

Ronney

Is there any solution for this yet? I see this network assembly is really buggy. I need this to work by next Tuesday. I’m getting the same error, but mine says Login Error – ERR access denied.

Hi,


We are working on this issue and will inform you as soon as it gets fixed. Sorry for the inconvenience.

When can we expect a fix? I really need a fix today for this. If you’re unable to provide a fix, I will have to choose another product to use. I’ve used the PDF library and this Pop3 library. I have yet to find something from aspose that works. Is this pretty typical with the aspose product line?

Hi,


Please find the attached hotfix for the login and memory exception issues.