We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Pound symbol shown as question mark

When i open a message in outlook it shows a ‘£’


When i open the message.BodyHtml using the Aspose.Email libraries it shows '?'

Is this an encoding issue as it doesn’t happen all the time… if so how can i fix it?

Cheers

Hi,

We are sorry for a delayed response.

I have tried to reproduce this issue at my end, but I am afraid that I couldn’t observe this problem using the latest release of Aspose.Email for .NET 3.1.0. Could you please try it at your end and let us know your feedback? If the problem still persists, please provide us a running sample application with screenshot of the problem. We’ll assist you further as soon as possible.

Hi,


just to be clear i am using the most recent version of your Aspose.Email library and this problem occurs when reading the message.BodyHtml property…message.Body shows the correct symbol (£).

MapiMessage msg = MapiMessage.FromFile(filepath);
msg.BodyHtml - contains '?500’
msg.Body - contains ‘£500’
I’d appreciate it if you would take another look at it…

Cheers

Hi,


I have analyzed the scenario again and used following code to re-produce the issue but am afraid to inform that I could not succeed. Please give a try to the following code with the latest Aspose.Email library and let us know the feedback as it displays £ in the body. Similarly I watched the Html body in debug mode and found the proper character in the body.

string dir = @"";
string filepath = dir + “problem - £ as -.msg”;
MapiMessage mapi = MapiMessage.FromFile(filepath);
MailMessageInterpretor mi = MailMessageInterpretorFactory.Instance.GetIntepretor(mapi.MessageClass);
MailMessage eml = mi.Interpret(mapi);
MailPrinter printer = new MailPrinter();
printer.Print(eml, dir + @“problem - £ as -.tiff”, Aspose.Email.Printing.PrintFormat.Tiff);
eml.Save(dir + @“problem - £ as -.mht”, MessageFormat.Mht, MailMessageSaveOptions.WriteHeaderToMht);

Using your code i don’t have the issue either…but if i use the mapi.BodyHtml i can replicate my issue, why is this? Is it using the wrong encoding?

Hi,


I tried again and am afraid to inform that I could not re-produce the issue. A snap shot is attached showing mapi Html body in debug mode using VS 2010.

Could you please elaborate how are you getting this issue? Please send us the snap shot and sample console application which can be used to re-produce this issue as it will help us to assist you as soon as possible.