PPT not converting to PDF

HI Attached files not converting to PDF.Please help.

package com.Aspose.example;

import com.aspose.ms.System.IO.FileNotFoundException;
import com.aspose.slides.PptException;
import com.aspose.slides.*;

public class slidesToPdf {

public static void main(String args[]) throws java.io.FileNotFoundException{
try {

//Instantiate a Presentation object that represents a PPT file
Presentation pptPresentation = new Presentation(“C:\Temp\SinglePDF\Standalone\Input\input.ppt”);

//Saving the presentation to PDF document

} catch (PptException e) {
// TODO Auto-generated catch block
} catch (FileNotFoundException e) {
//TODO Auto-generated catch block


Hi Anand,

I have worked with the presentation file shared by you and have been able reproduce the issue on my end. An issue with ID SLIDESJAVA-33416 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

Many Thanks,

Hey Mudassir,

I'm having the same issue with PPTX using Aspose.Slides 2.9.4.


import com.aspose.slides.Presentation;
import com.aspose.slides.export.SaveFormat;
import com.aspose.slides.pptx.PresentationEx;

PresentationEx pptxPresentation = new PresentationEx(source);
pptxPresentation.save(target, SaveFormat.PDF);


Caused by: java.lang.NullPointerException
at com.aspose.slides.obfuscated.brv.this(Unknown Source)
at com.aspose.slides.obfuscated.brv.for(Unknown Source)
at com.aspose.slides.obfuscated.brv.do(Unknown Source)
at com.aspose.slides.obfuscated.brv.if(Unknown Source)
... 69 more

Source file is attached, thank you!

Kind regards


Hi Peter,

I have worked with the presentation file shared by you using Aspose.Slides for Java 2.9.4 and have not been able to observe any issue. I have used JDK 1.6 in Windows 7 environment on my end. I also like to add that you need to use JAI jar files while rendering thumbnails or PDF. Have you included the same in your project. Please visit this thread link post to download the latest jar files and include them in your project.

If the issue is still there then please share the complete environment details along with JDK version with us for further investigation.

Many Thanks,


Could you please update whether the issue has been resolved?

Hi Anand,

I regret to share that this issue has not yet been resolved. However, I have requested our development team to schedule the issue for investigation and will share any further information as soon as it will be shared by them.

Many Thanks,


Could you please update on this issue?

We have a release this week using ASPOSE tool .It would be better if you fix this issue soon.Due to this issue our relase is getting delayed.

Thank you.\


Hi Anand,

Our development team has investigated the issue and have observed that the shared presentation “input.ppt” is in fact a PPTX presentation but named as PPT. This is in fact a not a bug and you can test is by accessing the given presentation using PresentationEx class. The following code will help you in this regard. Please share if I may help you further in this regard.

PresentationEx dest=new PresentationEx(path+“input.ppt”);
dest.save(path+“input.pdf”, com.aspose.slides.export.SaveFormat.PDF);

Many Thanks,

Hi Mudassir,

I have used saveas option in pptx and saved the file as ppt.Does it mean that I should not do like this?I accept I should not rename the file but when I use save as option it should work right?


Hi Anand,

If you share the presentation using PresentationEx.write() method and use the extension .ppt for file, the presentation will be saved as PPTX as the conversion of PPTX to PPT is currently not supported in Aspose.Slides for Java. However, when you open any PPTX presentation in PowerPoint and save that as PPT the the saved presentation will be saved as PPT. Renaming the file extension from PPTX to PPT will also not work in this scenario. I hope this will clear the concept before you.

Many Thanks,