We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PPT Slide Content Is Lost after Open/Save (1330)


When I load and save the attached file, the content of the second slide in the saved file disappear. Please see the attached screenshot for your reference.

Can you check this?

test.ppt.zip (1.5 MB)
1330.PNG (399.9 KB)



I have worked with presentation file shared by you using Aspose.Slides for Java 17.12.1 and unable to observe any content missing issue on second slide of saved presentation. I have also shared my generated result with you for your kind reference. Please check attachment. Can you please try to use Aspose.Slides latest version on your end and if there is still an issue than please share environment details so that we may further investigate to help you out.saved123.zip (712.7 KB)

Hi Adnan,

The same thing happens with the Aspose.Slides for Java 17.12.1. Here’s the generated file: test-aspose-17.12.1.ppt.zip (618.4 KB)


Presentation presentation = new Presentation("test.ppt");

presentation.save("test-aspose-17.12.1.ppt", SaveFormat.Ppt);

Env details:

Ubuntu 16.04 LTS 64bit

java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)

MS Office PowerPoint 2013 (15.0.4420.1017) 64bit



I have worked with the presentation file shared by you and have been able to observe the issue specified on ubuntu environment. An issue with ID SLIDESJAVA-36881 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed.

The issues you have found earlier (filed as SLIDESJAVA-36881) have been fixed in this update.