We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PPT Slides to Image --- loss of content

Hello,


I am evaluating the SDK, and I faced a few problems while converting PPT slides to images… specifically related to loss of content — something which is there in the slides is missing in images. I have a few questions in this respect:

1. Are these issues known? Are such customer-reported issues handled/fixed at priority?
2. How frequently are the updates etc. released?
3. Are the updates freely made available to existing customers?

Regards,
Ankur Kashyap

Hi Ankur,


I have tried to understand the issue shared by you. It will be very nice of you, if you may please share the source presentation along with code snippet. Please also share the output images by highlighting the issues in them for our knowledge so that It can be reproduced on our end. I appreciate your cooperation in advance for this.

Secondly, the product release is made on quarterly basis in one calender. Also, if there are hotfix available, there are released in between two successive product releases. Lastly, the customers get the subscription for one year and he is entitled to all of product release ad hot-fix versions that are shared before expiry of subscription. Hope it answers the questions shared by you.

Thanks and Regards,

Hello,


Thanks a lot for replying.

I have attached a sample PPTX with one slide and the converted TIF file. You may notice some graphics are missing the in the resulting image. I noticed similar issues in multiple PPTX file.

I understand that ASPOSE library must be a huge/complicated project… such bugs are not a major problem. However, if a customer notices such issues, and reports to you, how quickly can a resolution be provided. With this background I had made the last post.

The code is very simple:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

using Aspose;
using Aspose.Slides.Pptx;

namespace PPTTest
{
class Program
{
static void Main(string[] args)
{
PresentationEx pres = new PresentationEx(@“C:\Users\Administrator\Desktop\Test1.pptx”);

pres.Save(@“C:\Users\Administrator\Desktop\Test1.tif”,
Aspose.Slides.Export.SaveFormat.Tiff);
}
}
}

Hi Ankur,


I have worked with the presentation shared by you and have been able to reproduce the issue shared. This issue has already been logged in our issue tracking system with ID 30835. This issue has also been linked with the issue so that you may be automatically notified once the issue is resolved. I would suggest you to please use Aspose.Slides for .NET 2.0 version dll as it does not exhibit the same issue.

We are sorry for your inconvenience,

The issues you have found earlier (filed as 30835) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as SLIDESNET-30835) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(5)