Free Support Forum - aspose.com

PresentationEx Write method slow

I’m currently generating a presentation with 58 slides, the total time it takes to create each slide is 2,5 secondes, the slides are cloned from a template slide.
When all the slides are generated, I save the presentation using the Write method and I provide a file location. This takes +/- 2,5 secondes, why is this so slow?


Hi Vincent,


Thanks for your feedback. Can you please share the sample project highlighting the issue along with source and generated presentations. Please also share the system and environment specifications where you are using Aspose.Slides for .NET your investigation. I will try to reproduce the issue on my end to help you further.

Many Thanks,

Hi Mudassi,

Thanks for your reply, I’ve added a sample project which reproduces my problem in the attachment of this post.

My system and environment specs are:
Windows 7 (64 bit) - Intel Core Duo 2.5Ghz - 4GB RAM
Aspose.Slides version 5.9


Hi Vincent,


I have observed that you are using Aspose.Slides for .NET 5.9.0 on your end. I would suggest you to please try using Aspose.Slides for .NET 6.9.0 on your end share your feedback. I will then create an issue in our issue tracking based on your feedback.

Many Thanks,

Hi Mudassir,

I just tested it with the latest version of Aspose Slides 6.9 and it stays the same or even a bit slower.

Hi Vincent,


Thanks for sharing the sample project. I have used the sample project using Aspose.Slides for .NET 6.9.0 and have been able to achieve the presentation save method working in 3.2 seconds in my environment. I also like to add that we are taking some measures to improve the performance of the Aspose.Slides for .NET API and it will be improved in subsequent versions of Aspose.Slides for .NET. I have created an issue with ID SLIDESNET-33882 as performance issue in our issue tracking system so that our development team may further investigate the issue on their end. I will share the updates with you as soon as the feedback will be shared by our development team.

Many Thanks,

The issues you have found earlier (filed as SLIDESNET-33882) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.