We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Printing to a postscript printer

Hi

Our documents now look as we were hoping when viewed in acrobat reader 7. However when we print to our postscript printers we get error messages appear and any text entered by aspose.pdf has become garbled.

We use a word document as a template to fill the information with a mail merge, and the word document section appears correctly.

We’ve tried two different printers, a Kyocera and a Xerox, both gave similar results.

This only occurs when we add the security object to the PDF. Without security the pdf prints fine.

Do you have any suggestions on how to fix this? I’ve attached a pdf so you can try and repeat the error yourself. Just open it with adobe and print.

Dear Stuart,

Thank you for considering Aspose.

I have reproduce this error but I don't know the reason. I will check this issue but it may take much time since this problem is not easy to solve.

Has any progress been made on this?

Our initial efforts allowed us to generate the PDFs we needed but we are now being asked to make them downloadable. Although uploading what we have is possible we’d like to prevent anyone downloading the file from altering them.

I have played with the security object and it has all the options we need to prevent editing but the bug that corrupts the printout on certain printers is a real problem for us now.

Sorry I have not found the reason of this problem. I hope I can solve this problem late next month.

When I try to print the document into Adobe PDF converter, I get the following message:
This PostScript file was created from an encrypted PDF file.
Redistilling encrypted PDF is not permitted.

So I think printing encrypted PDF to PostScript printer is not permitted. If I am wrong, please correct me.

The attached document is generated by another piece of PDF software (Dynamic PDF by CETE Software) that we use. It only allows printing and accessibilty access and has 128 bit encryption. The document prints correctly on our postscript printer.

Im not sure what Adobe PDF convertor is so I couldnt test to see if it gives the same error. As I said it does print correctly though

I’ve tested some more on this - By removing all formatting from our template document I have been able to make the document print the first three paragraphs in a legible format. The printer then stops printing and creates a page with the message

ERROR: syntaxerror
OFFENDING COMMAND: binary token, type=157

STACK:

/d -q-l !`
[(XKLAAA+LucidaSasUnicode)]
/Identity-H
(XKLAAA+LucidaSansUnicode-Identity-H)
/N14
-savelevel-

I’ve attached that document incase any of this helps.

I think the info you provide is helpful. I will try to solve this problem ASAP.

Since I have no PostScript printer, do you know if there is a method to check whether a pdf document can be printed by PostScript printer?

Dear,

Has this issue ever been resolved?

We have pdf's generated from word documents via XML binding, but they fail to print on some certain printers, especially postscript printers.

Hi,

Sorry for the delay. I have confirmed that the issue is not resolved yet. Currently, we have some problem to reproduce the error at our end. We will investigate more on it. However, I don’t think it could be resolved in short time. Sorry for inconvenience.

Best regards.

Hi,

Has this issue ever been resolved?

Regards

Hi Filipe,

Thanks for your interest in our products.

Can you please share some details regarding the issue you are facing and we would appreciate, if you create a sample application and post here along with template documents to show us the issue. This will help us to regenerate the issue and get the cause of the issue soon.

We apologize for your inconvenience.

Thanks & Regards,

Hi,

My problem is that when I set security settings to a PDF it gives error when trying to print it in a postscript printer.

Starting from the beggining, we have an application working till now using aspose pdf (4.0). From the begining when we send the pdf files produced with aspose with security options to our printing system (a centralised system with postscript printers) it gives error when printing. Solution was not to set any security options and printing works fine.

But now, it is mandatory to have a secured pdf not allowing copying. I have no direct access to postscript printers so I am using PDFCreator (v1.3.2) for my tests.

I built a small project in which I create a pdf file using aspose with some security settings (see teste.pdf). If I try to print that file to a PDFCreator printer I receive an error (see printed_file.pdf). If I do not apply any security setting I am able to print it without any problem. This happens using aspose PDF 6.8.

Can you help me on this?

Thanks and Regards

Hi Filipe,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for sharing the sample application.

I am able to generate your mentioned issue after testing your sample application. Your issue has been registered in our issue tracking system with issue id: PDFNEWNET-33586. You will be notified via this forum thread regarding any updates against your issue.

Sorry for the inconvenience,

The issues you have found earlier (filed as PDFNEWNET-33586) have been fixed in Aspose.Pdf for .NET 9.8.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.