We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem in using office 2007 presenatation object

Hi Team,

I have powerpoint template which is developed in office 2007,when i try to open the file it is throwing an error.

I have developed a class which is using aspose.slides.Presentation class ,when i tried to open the "powerpoint.pptx " file it is throwing an error .Below is code

Aspose.Slides.Presentation AspPresentation = new Aspose.Slides.Presentation(


Please suggest the solution to open in pptx files and assign it to presentation object without using Presentationex class.

Hi Kumar,

Thanks for your interest in Aspose.Slides.

I have observed the code snippet shared by you. In may observation you are probably using Aspose.Slides.Presentation class to access the PPTX presentation. However, the said class can only support PPT presentations. In order to access the PPTX presentation please use PresentationEX class. If the problem still persists then please share the source presentation along with code snippet for further investigation.

Thanks and Regards,

Hi Fayyaz,

Thank u for your fast reply.

using presentationEx class when i tried to clone a slide i am getting below error

"Object reference not set to an instance of an object."

below is my code

Aspose.Slides.Pptx.SlideEx templateSlide = ObjPPPt.Slides[ObjPPPt.Slides.Count - 1];

ObjPPPt.Slides.InsertClone(ObjPPPt.Slides.Count,templateSlide );

I am using latest version of aspose dll.Please provide the solution .

Note:I have attached the project solution files.

Thanks & Regards

Kumar Reddy E

Hi Kumar,

I am afraid that I am unable to find the shared presentation. Can you please verify the things on your end ?

Thanks and Regards,

Hi fayyaz

I sent solution files through an email

Hi Kumar,

I am afraid that I have not been able to receive the solution files shared by you owing to some probable mail server issue. In order to expedite the process, you may also share the solution files on forum by setting the conversation to private mode.

I really fell sorry for this inconvenience,