Free Support Forum - aspose.com

Problem opening excel template-file

Hi.

I have a strange problem.

Using version 3.3.1.0 and version 3.3.0.0 of the excel component, I am not able to open the attached file. The error message is : “Index was outside the bounds of the array.”. Using version 3.2.0.0 I can open, modify and save the file.

The code I use (the arguments for the open-method leads to the actual file):

Excel xl = new Excel();
xl.Open(templatesPath + ConfigurationSettings.AppSettings[“TimeDistribution”] + “.xls”);

Seems to me there is some functionality that is lost along the way. Is this something you could look into?

Regards Edvin.

In MS Excel, all drawing objects are related to each other. In these new versions, we tried to access images and charts in designer templates. This caused this bug. I fixed it. Please try the attached dll.

Hei again.

I have downloaded the latest version (v.3.3.3.0) from the download-pages. I still get the same error (and error-message).

I re-tested your file and didn't find your problem. The following is my test code:

Excel excel = new Excel();

excel.Open("c:\\Time distribution v2.xls");
excel.Save("c:\\result.xls");


I added some new features in this new attached dll. Please try it. And please verify that your project refers to this new dll. You can remove reference to Aspose.Excel and re-add this reference in your project.

Hei again.

Now it works. Thank you very much.

Regards Edvin.