We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem setting acw_client_path for GridWeb

I am having trouble setting a custom acw_client_path for the GridWeb control (or any path that allows the control to function correctly). I am using the latest version of both the Cells and GridWeb .dll, and I have a paid license file that is correctly applied. I have tried setting the acw_client_path in three ways:

appSettings in web.config:

In the .aspx file:

In the .cs code file:
GridWeb1.ACWClientPath = "/assets/acw_client/";

In all cases, the images in the GridView (like the backward and forward arrows) appear, but the grid is not functional and the cell headers (A,B,C,D) do not line up with the columns below. The source of the page shows the code below.

Note that image_file_path="/assets/acw_client/" seems correct, but acw_client_path="/lms/admin/ad_doc_viewdocument.aspx/" is wrong -- "ad_doc_viewdocument.aspx" is the page that the control is located on.

Interestingly, whenever I add this line to the appSetting in web.config and then view a page with a GridWeb control, IE 8 crashes"

Any thoughts on a solution?

Thanks,

-Tim

Hi,

If you are using IE8, GridWeb might have some compatibility issue. As a workaround, there are two options that can be used to resolve the issue without setting IE8 compatibility mode manually, please choose any one for your requirement when you make development using Aspose.Cells.GridWeb control.

1. Add into header section of html which contains gridweb control. The code is like this:





Untitled Page



2. Configure the IIS settings, add the custom header(X-UA-Compatible) and value (IE=EmulateIE7). This solution will apply the custom header to all requests.


Thank you.