We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem while loading .odt into aspose.words Document object

Hi,

I was doing some tests with Aspose Words and I ran into a little issue. Simply put, when I load a certain type of .odt file into a com.aspose.words.Document and then save it, the output file looks different from the original file. The code I used for the test is simple:

Document ODTFile = new Document(“c:/users/prog2/desktop/fusiodat.odt”);
ODTFile.save(“c:/users/prog2/desktop/fusiodat_aspose.odt”);

I don’t know if the issue has something to do about the template I used for the original file, I guess it does in a way since the other templates worked just fine, apparently. But since OpenOffice and LibreOffice showed the document correctly before loading and saving with aspose.words I thought there maybe an problem with how aspose process it.
I attached the two files, fusiodat.odt is the original one.

Thank you,
Sergio.

Hi Sergio,

Thanks for your inquiry.
I have tested the scenario and have managed to reproduce the same
issues at my side. For the sake of correction, I have logged these
problems in our issue tracking system as follow:

WORDSNET-12087 : Page margins are changed after re-saving Odt
WORDSNET-12088 : Content position is changed after re-saving Odt

I
have linked this forum thread to the same issues and you will be
notified via this forum thread once these issues are resolved.

We apologize for your inconvenience.

The issues you have found earlier (filed as WORDSNET-12087;WORDSNET-12088) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.