Free Support Forum - aspose.com

Problem with Calculation Engine - Invalid Object Reference

With Aspose.Cells 4.4.0.1 the attached worksheet cannot be calculated. When executing CalculateFormula an “invalid object reference” error is thrown.

The worksheet is very easy, only three cells are filled. No functions from addins are used. Only Excel functions are used.

Michael G. Schneider

We will fix this issue soon.

Hello Laurence,



thanks a lot for the answer. I will try the fix as soon as it is available.

Michael G. Schneider

Please try the fix attached at <A href="https://forum.aspose.com/t/92391 .

Hello Laurence,

the file that I sent to you yesterday was a small extract from a large customer’s file. I tried the new version of Aspose.Cells with the large customer’s file. Executing CalculateFormula made Aspose.Cells go crazy. It worked for about 10 seconds, then a System.OutOfMemoryException was thrown.

I would like to send you the large file by private email. Should I use your email adress that I know from last year?

Michael G. Schneider

Hi,

Did you try the latest fix (4.4.1.6) which Laurence has attached in the other thread he mentioned?

If you still find any issue, post your large file @: nanjing@aspose.com We will check it soon.

Thank you.

Yes, I did try that version. However, things are very strange right now.

There was a zip attached to the other post. This zip was 825KB. It contains an Aspose.Cells.dll, which is 2157KB. The version of this dll is indeed 4.4.1.6.

However, my previous Aspose.Cells.dll was 2697KB.

Would you please check that file. Is it possible that there is a dotnet v1 / v2 mixup?

Michael G. Schneider

This dll is built on .Net1.0.

For the dll of 2697KB, I think it's built on .Net2.0.

Please zip and send your file to nanjing@aspose.com. I will check and fix it ASAP.

Hello Laurence,

wouldn’t it be better, if you just give me the newest Apose.Cells for dotnet 2?

What I have obviously done is as follows. I downloaded the Aspose.Cells from the other thread. Not knowing that this is the dotnet v1 version. Then I copied this file over my dotnet v2 version. Then things started to go wrong.

Michael G. Schneider