Problem with equations on different operating systems


#1

Hi there,


we’re experiencing some issues when trying to convert Powerpoint slides with embedded equations.
On windows the equations are transformed, on a SLES system they were not. After a litte bit of investigation it seems to be a problem with already installed fonts on the respective system.

Is there some kind of list of fonts that are necessary for all built-in features of powerpoint to work?


Kind regards
Tim

#2

Hi Tim,

I have observed the requirements shared by you and like to share that there is no font requirement as far as Aspose.Slides is concerned. Aspose.Slides needs those fonts during rendering that are used in the source presentation. Aspose.Slides offers to load the fonts used in presentation without installing them by loading them from external directories. I suggest you to please copy the fonts from Windows directory to Operating system instance where you are getting rendering issue. Then use the following statement in your sample application at the start after loading license and before loading the presentation.

FontsLoader.loadExternalFonts(new String[]{path+"//freefonthome//"});

The FontsLoader actually loads the fonts externally from the directory without installing them. Please try using the suggested changes using Aspose.Slides for Java 7.9.0. If there is still an issue then please share the sample code, presentation, Windows generated output and SLES generated output with us. Please also share the Java details with us as well.

Many thanks,

#3

Still doesn’t work as I expected. Basically I’m doing the following:


// load external fonts if fonts path is defined
String externalFontsPath = System.getProperty(SLIDES_EXTERNALFONTS_PATH);
if (externalFontsPath != null) {
FontsLoader.loadExternalFonts(new String[] {externalFontsPath});
}
Presentation presentation = new Presentation(is);
presentation.save(baos, SaveFormat.Pdf);
FontsLoader.clearCache();
return baos;

I’ve attached input powerpoint and botch win and sles output pdf. The font (Cambria Math) is in the font directoy.


Kind regards,
Tim



#4

Hi Tim,

I have worked with the presentation file shared by you and have been able to observe the issue specified in Windows environment using Aspose.Slides for Java 7.9.0. An issue with ID SLIDESJAVA-34163 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,


#5

Hi,


just a follow up question. Is it possible to view your JIRA items regarding progress etc.? - If so, how?


Kind regards,
Tim

#6

Hi Tim,


I like to share that unfortunately there is no direct access to our issue tracking system for our worthy customers. However, you can view the status of the issue from the very first row of the thread. For your kind reference, I have attached the image that highlights the position from where you can view the status.

Many Thanks,

#7

Hi,


thanks for the quick reply. I’ve already noticed the issue on the left.


Thanks,
Tim

#8

The issues you have found earlier (filed as SLIDESJAVA-34163) have been fixed in this update.