We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem with track changes and highlighted text

Hello,

I have a document with track changes enabled and some highlighted text.
When I remove the highlighting of the text, a track changes is made, but when I open the document with Aspose.Word (for java) and the save it again, this track change dissapears.
Here is a sample code I’m using to open and save the document:

Document d = new Document("C:\highlighttest.doc");
File f = new File("C:\highlighttest2.doc");
FileOutputStream fos = new FileOutputStream(f);
d.save(fos, SaveFormat.DOC);
fos.flush();
fos.close();

The document with the track change is attached.

Sorry for my poor English

Hi
Thank you for reporting this problem to us. I managed to reproduce this problem and created new issue #5483 in our defect database. This issue will be fixed in .NET baseline and then ported to java version. I will notify you as soon as it is fixed.
Best regards.

Ok, thank you

The issues you have found earlier (filed as 5483) have been fixed in this update. This fix will be ported to java version soon.

Thank you, waiting for the Java version

Hi,

The new release of the java version is out today, but as I can see, the bug 5483 is not fixed in it.
I was waiting for it and my company really needs this change.
As there is between three and six months between each java release, how long will I have to wait now ?
Thanks.

Hi
Thanks for your inquiry. Unfortunately Aspose.Words for java v2.5.0 does not include fix for issue #5483. This release includes all changes and fixes we’ve made earlier on Aspose.Words for .NET versions 4.4.0 to 5.2.0.
But issue was fixed in Aspose.Words v5.2.2. So this fix will be included in the next Aspose.Words for java release (it will be published within 2-3 months). Sorry for inconvenience.
Best regards.

Hi,

You said the fix will be included in the next Aspose.Words for java release.
Today a new release has been made (2.6.0), but still no bug fix for bug #5483
I hope I won’t have to wait six months to see this bug fixed.

Hi
Thanks for your request. This release does not include any fixes. We included DOCX import module in this release. Bug fixes will be ported to java version within month I think. Sorry for inconvenience.
Best regards.

Hi,

I reported this bug eight months ago and still not in the Java version.
The one year update for my licence will expire on 17 February.
I hope a new version will be released before, cause I think I should not have to by a licence renewal for a fix I asked eight month ago.

Thanks.

Hi
Thanks for your request. We will try to include this fix in the next version of Aspose.Words for java. It will be release within a week.
Best regards.

We have published new version of Aspose.Words for java. This version contains fix of issue #7406 (.net #5483) you have reported earlier.
You can download new version from here:
https://releases.aspose.com/words/net