We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Problem with ttf-mscorefonts and percentages + arrowhead missing

Hi. I’ve noticed there is a problem when trying to convert excel chart into svg. In windows environment everything works fine but the problem occurs in linux environment. There are 2 problems.

First one is related to missing percentages for positive numbers. That happens only when ttf-mscorefonts is installed. Please check AsposeBug.zip where you can find dockerized demo project written in .net core. Notice lines 8-13 in dockerfile. If docker image is created without them (font not installed) then percentages appear and if docker image is created with them (font is installed) than percentages do not appear for positive numbers.

RUN apt-get update
RUN apt-get install -y --no-install-recommends software-properties-common
RUN apt-add-repository contrib
RUN apt-get update
RUN echo “ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true” | debconf-set-selections
RUN apt-get install -y ttf-mscorefonts-installer

Second one is arrowhead missing problem as you can see on image arrow_head_missing.png that is attached to this post and marked with red square. That is not caused by font installed or not. It is caused only by using linux environment.

I’m using linux debian gnu linux 10 (buster) 64 bit. I’ve used latest version of aspose.cells 21.7.0.

arrow_head_missing.png (30.5 KB)
AsposeBug.zip (180.6 KB)

@ottap,
The missing arrow head issue is reproduced and logged in our database for further investigation. This issue is logged as:
CELLSNETCORE-137 - Arrowhead missing while converting Excel to SVG

Regarding the other issue where % character is missing with positive numbers (when ttf-mscorefonts is installed), this issue is not reproduced. I have tried this scenario by commenting/un-commenting the lines in docker file multiple times but still no success. This issue needs further investigation therefore it is also mentioned in the ticket.

1 Like

Hi @ottap
Please use our latest patch, we have optimized for this problem, please let us know your feedback.
Aspose.Cells21.8.1 For .NetStandard20.Zip (5.6 MB)

Hi @leoluo,

I confirm that the bug is resolved with this patch. Thank you!

@ottap,

Good to know that your issue is resolved by the new fix. In the event of further queries or issue, feel free to write us back.

The issues you have found earlier (filed as CELLSNETCORE-137) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao