Free Support Forum - aspose.com

Problem with worksheet styles being copied between workbooks

Laurence,



for whatever reason my yesterday’s post regarding this problem was deleted! So, I try again…



When you run the attached sample application and check out the Sheet 17 of the resulting

Test.xls, you will notice strange borders on cells that are neither present on the original

Envelope.xls nor on FK4.xls. It seems like these are being introduced when copying

worksheets across workbooks.



This has been tested with version 3.4.0.4. When I run the sample with 3.5.0.0 I get the

same behavior but also an error that data might be lost (when I open Test.xls)



Any help would be appreciated.



Kai

Hi Kai,

Since v3.5, copying worksheets between workbooks also copys drawing object which includes images, charts, etc. That's a complex feature. Your problem may be caused by this. I will check and fix this issue in about one week. Thanks for your patience.

Laurence,



thanks for getting back to me. I can live with a week or two (for the
moment ;)), but I was curious as I haven’t seen a reply on my initial
(private) post.



However “Data missing” issue might be related to the 3.5 release, but
the strange borders showing up on one of the sheets is related to 3.4
(and possibly earlier). Maybe it has anything to do with the changed
workbooks that we have received from business.



Regards



Kai

Hi Kai,

These two issues are all resolved. Please try this attached fix.

Laurence,



thanks for the quick fix. Works like a charm.



Regards



Kai