We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Protection identification issues Slides 15.8

Scenario: I use Slides to identify whether file is 1) encrypted; 2) write protected.


Issue:
  • Write protected POT/PPT. ProtectionManager.IsWriteProtected returns false. Valid value is returned for Office 2010 formats (PPTM…).
  • Encrypted POT/PPT. ProtectionManager.IsEncrypted return false.

Have not tested on PPS.

Sample files attached.

Password to opne/modify: “1” w/o quots.

Hi Deepak,

Thank you for posting.

I have observed your requirements and worked with the presentation file shared by you. I have been able to reproduce the issue. A ticket with ID SLIDESNET-36878 has been logged in our issue tracking system to further investigate and resolve the issue.This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

Also, I would like to add that POT format is not supported by Aspose.Slides however POTX format is supported. This issue has been logged into our issue management system for the resolution of issue with ppt file format

We are sorry for your inconvenience,

Hi


Any progress since 10-09-2015 4:26?

Thanks,
Alex

Hi,


I have observed your comments. I like to share that issue is still unresolved and scheduled for this week for additional investigation and estimation. Our product team is investigating issue in details. We will share good news with you soon.

Best Regards,

Is there any movement?


Update based on Aspose.Slides 17.4

  1. Legacy formats with write-protection (ppt, pps).
  • ProtectionManager.IsWriteProtected returns FALSE. TRUE is expected.
  • ProtectionManager.IsEncrypted returns TRUE. FALSE is expected.
  • Legacy formats with both kinds of protection: open and write.
    • ProtectionManager.IsWriteProtected returns FALSE.

    It seems that the following issue from the initial post has been fixed as I cannot replicate it: Encrypted POT/PPT. ProtectionManager.IsEncrypted return false.


    Thanks,
    Alex

    Hi Alex,


    I have worked with presentation files shared by you using Aspose.Slides for .NET 17.4 and unable to observe the issue. After investigation on this issue, i can say that this issue has been resolved in Aspose.Slides for .NET 17.4 . Please share feedback with us if there is still an issue.

    Best Regards,