We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Provider com.aspose.ms.charsets.utf7.UTF7CharsetProvider not found

Hi,

I am using aspose-pdf-new-4.0.0.jar to split PDF documents. When I try to connect to our Content Management system, I get the below error. I cant seem to find the provider refereced in by java.nio.charset.spi.CharsetProvider file in aspose-pdf-new-4.0.0.jar.

Not sure if there are classes missing or problem in my deployment.

Exception in thread "Thread-0" sun.misc.ServiceConfigurationError: java.nio.charset.spi.CharsetProvider: Provider com.aspose.ms.charsets.utf7.UTF7CharsetProvider not found
at sun.misc.Service.fail(Unknown Source)
at sun.misc.Service.access$000(Unknown Source)
at sun.misc.Service$LazyIterator.next(Unknown Source)
at java.nio.charset.Charset$1.getNext(Unknown Source)
at java.nio.charset.Charset$1.hasNext(Unknown Source)
at java.nio.charset.Charset$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.nio.charset.Charset.availableCharsets(Unknown Source)
at com.documentum.fc.common.DfPreferences$CodepageHandler.(DfPreferences.java:1695)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at com.documentum.fc.common.DfPreferences.getRawPreferenceMetadata(DfPreferences.java:275)
at com.documentum.fc.common.DfPreferences.access$000(DfPreferences.java:35)
at com.documentum.fc.common.DfPreferences$1.run(DfPreferences.java:126)
at com.documentum.fc.common.DfPreferences$1.run(DfPreferences.java:122)
at java.security.AccessController.doPrivileged(Native Method)
at com.documentum.fc.common.DfPreferences.getRawPreferenceMetadataFromAnnotations(DfPreferences.java:119)
at com.documentum.fc.common.DfPreferences.initialize(DfPreferences.java:61)
at com.documentum.fc.common.DfPreferences.getInstance(DfPreferences.java:43)
at com.documentum.fc.common.DfFileWatcher.getConfigCheckInterval(DfFileWatcher.java:31)
at com.documentum.fc.common.DfFileWatcher.run(DfFileWatcher.java:54)

Hi Zirk,


Can you please share the source PDF file and the code snippet that you are using so that we can test the scenario at our end. We are sorry for this inconvenience.

Hi,

I am not even calling the Aspose portion of the code. I am connecting to our CM to retrieve the document to split, but I cant connect. I get the same error as above.

It cant find com.aspose.ms.charsets.utf7.UTF7CharsetProvider in the classpath. I also cant seem to find it in the package, aspose-pdf-new-4.0.0.jar.

I have tried loading the jar files, one before the other and the other way around but with no luck.

Where can I find the following: com.aspose.ms.charsets.utf7.UTF7CharsetProvider

Same issue here but only in unit testing with jUnit. Seems to work well otherwise.

Can't load my spring context.

Aspose jars are there.

Appeared when we started using new jar aspose-pdf-new-4.0.0.jar

What am I not getting?

thank you

Hi there,


Sorry for the inconvenience faced. We have already logged a similar issue as PDFNEWJAVA-33509 in our issue tracking system for investigation. I’ve linked your request to the issue and we will keep you updated about issue status via this forum thread.

Please feel free to contact us for any further assistance.

Best Regards,

Hello,

For information, I encounter the same issue.
Please, keep us informed on status of this bug’s correction.

Thank you.

Regards.

Hello,

For information, I encounter the same issue. when we are connecting to documentum in our application
Please, keep us informed on status of this bug’s correction.

Thank you.

Puruhsotham

Hi Puruhsotham,


Thanks for you inquiry. We have a good news for you the above reported issue has been resolved and fix for the issue will be included in upcoming release of Aspose.Pdf for Java 4.1. Currently the release is in process of integration and testing, however we will update you via this forum thread as soon as it gets available for download.

Thanks for your patience and cooperation.

Best Regards,

The issues you have found earlier (filed as PDFNEWJAVA-33509;PDFNEWJAVA-33509) have been fixed in Aspose.Pdf for Java 4.1.0update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(1)