We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

PST item EML output saves date with weekday abbreviation on server but not on desktop

When extracting an EML from an outlook PST the email date in the EML contains the weekday abbreviation on the server but not on my developer workstation.

I’d like the behavior to be the same no matter what system it runs on.

Here is the code I’m using to convert a message to EML:

var interpreter = MailMessageInterpretorFactory.Instance.GetIntepretor(_mapiMessageItem.MessageClass);
var mailMessage = interpreter.Interpret(_mapiMessage);
mailMessage.Save(outputStream, SaveOptions.DefaultEml);

I’ve tried changing the Culture on the Current Thread and Current AppDomain without success. What governs the output of the message date to the EML format? How can I control it?

Hi Bret,

Thank you for contacting Aspose Support team.

This doesn’t have to do something with Aspose.Email API and seems to be dependent on system settings. A quick search on Google presents a number of methods to change the date/time display format. Please have a look at these and let us know if we can be of any additional help to you in this regard.

PS: If you drag a message from PST opened in Outlook, save it to disc, and then open it by double-clicking it, it will open in Outlook with the same date/time format as you have mentioned. Thus, it is not an issue at Aspose.Email API end.


Thank you for your quick response.

The problem I’m trying to solve is how to control how Aspose Email .Net outputs dates in the EML format. I’m not looking through a tool such as Outlook - I’m looking directly at the EML file using a plain text editor.

When I look at an EML file I have output on my workstation using a plain text editor, I see output similar to the following (data scrubbed and truncated):

From: “Somebody” <@.com>
To: "@.com" <@.com>
Subject: Some Subject
Date: 18 Jun 2014 12:14:58 -0800

When I look at the same EML file our system has output on a hosted server using a plain text editor, I see output similar to the following (data scrubbed and truncated):

From: “Somebody” <@.com>
To: "@.com" <@.com>
Subject: Some Subject
Date: Wed, 18 Jun 2014 12:14:58 -0800

I would like the date output to be the same no matter what system it is run on.

Since the date output format is different on various machines, it must be being affected by something - - but I’m unable to find out exactly what is affecting it.

I have tried changing the Thread and AppDomain culture prior to outputting the message and it did not affect the output format of the date - - even though making this change affected the DateTime.ToString() output format.

I have compared the operating system settings between my workstation and the hosted server and they are identical (see attachments).

If an Aspose developer could look at the source code and see what affects the date output format it likely would save me considerable investigative time.


Hi Bret,

Thank you for clarification.

We have tried different ways to make this expected output change as per system’s settings, but were not able to get success. We are further investigating the matter at our end and will soon update you here with our findings. We appreciated your patience in this regard.

Hi Bret,

We have forwarded this issue to our Product team for their feedback via issue id: EMAILNET-35192 and will update you here as soon as there is some information available in this regard.

The issues you have found earlier (filed as EMAILNET-35192) have been fixed in this update.

This message was posted using Notification2Forum from Downloads module by Aspose Notifier.