Publishing Report failed


#1

Hi,

I’m evaluating the Aspose.Cells for Reporting services.

I have downloaded / installed the latest version of the software. Currently for evaluating I’m using:

  1. OS windows 7
  2. SSRS /MS SQL 2016
  3. Excel 2016 32 Bit

At present I’m able to open the RDL file from remote sever in excel and when I’m trying to publish the same (without any changes) its breaking.

The message I’m getting ‘Publishing Report failed.’ without and further details.

Also i tried enabling the LOG’s. Below are the steps I performed.

  1. Change Level Value within logger to Debug within ‘Aspose.Cells.ReportingServices.xml’ at ‘Program Files\Aspose\Aspose.Cells for Reporting Services’ folder;


  2. Also given myself full control on the installation folder ‘Program Files\Aspose\Aspose.Cells for Reporting Services’.

Still logging is not working.

Please let me know that what i’m missing and

  1. WHY i’m unable to publish report and
  2. Logging not getting enabled…

Thanks


#2

@sumeetmadan,

Thanks for the details.

Make sure you update the value of logger level to debug on Aspose.Cells.ReportingServices.xml (client and server).

==============================================================================

    <Aspose>
    <logger>
    <level value=“Debug”/>
    </logger>
    … ==============================================================================

Re-save and try to re-publish report definition file on client.

If you still find the issue, kindly provide RDL, Aspose.Cells.ReportingServices.xml file, logs (if found) and some screenshots to demonstrate the issue, we will check it soon.


#3

Thanks!

I already made the required changes as specified. But logging was not working.

Only after I restarted the SSRS & SQL services, the log file started getting created.


#4

@sumeetmadan,

Kindly provide RDL, Aspose.Cells.ReportingServices.xml file, logs file(s) and some screenshots to demonstrate the issue, we will check it soon.


#5

What I have found the work sheet name was “Parts1-2”. And when I tried to publish the xls the publishing was failing. So I then changed the sheet name to “Parts12”, I was able to publish the xls without any issue.

So please clarify:

  1. The file we have has sheet name containing Spaces and “-”. And we cannot change the file as the xls is PASSWORD protected. So how can we publish xls which has “-” and Spaces in the sheet name.

This has become show stopper for as this is Mandatory requirement.

Pls Advice.


#6

@sumeetmadan,

Thanks for providing further details.

We need to evaluate your issue thoroughly. I have logged a ticket with an id “CELLSRS-564” for your issue. We will investigate and look into it soon. Once we have an update on it, we will let you know.


#7

@sumeetmadan,

The name of report item must be CLS-compliant identifiers in SQL Reporting Services report. The name of report item is made with sheet name cell row and column by Aspose.Cells for Reporting Services report designer. So the sheet name can not include “-” in excel file.