Quality of generated images is low: Lines are not rendered fine

I hope you can help me with the quality of the images generated with ASPOSE.

For example, if you visualize the purple lines in the following image generated with AUTOCAD. You can see that they are thick lines.
AUTOCAD.png (198.5 KB)

On the other hand, when I generate an image of the same plan above, the lines come out thin (the image must be in grayscale):
ASPOSE.jpg (199.5 KB)

I am using the following code to generate the images:
image.png (40.0 KB)

I need the images generated with ASPOSE to respect the thickness of the lines defined in AUTOCAD.



I request you to please share the source CAD file along with generated output and used sample code. I will be able to investigate the issue further on my end on provision of requested information.

Hi @mudassir.fayyaz

Source CAD:
BT_Hawa_Frontino_20H FS ul_TH_3_Color.zip (562.0 KB)

Sample Code:
Sample code.zip (6.3 MB)

Thanks for your help!


Thank you for sharing the information with us. A ticket with ID CADNET-8246 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

1 Like


We have investigated the issue further on our end. In order to proceed further with investigation on our end, we need to know, how you have exported to image in AutoCad and which commands you have used or which buttons. There are different ways depending on the way you have generated this image is important.

We also need the Plot Style Table. There is “Hawa.ctb” plot style table used in this drawing, it is the separate custom file. If possible, we need it too.


I send you the requested information:

How to export an image from Autocad
Export image.zip (428.5 KB)

Plot Style Table
plotstyletable.zip (3.4 KB)



Thank you for sharing the feedback. I have associated that in our issue tracking system and will share the feedback with you as soon as it will be shared.

Is there news about this issue?

Friendly regards!


I suggest you to please try using latest Aspose.CAD for .NET 21.8 on your end. The following are our findings.

  1. About lineweights please see the attached document (8246.docx) for convenience. There is explanation and code example.

  2. Additionally, we have fixed the issue with missing dimension values for color images and the usage of colors from CTB files for the drawing.

  3. Option for greyscaling of the image may be skipped, now colors are got correctly from CTB file.

Options 2 and 3 will be available according to release schedule for 21.8.

Etalon result has been added too.

BT_Hawa_Frontino_20H FS ul_TH_3_Color.dxf.jpg (661.4 KB)

8246.docx (29.1 KB)


I have a similar ploblem that the line becomes thicker when converted with Aspose CAD for .NET
Can you share the “8246.docx” file because I want to read that explanation and code example.?

I want to know how to set CTB files for Aspose CAD for .NET.

This is the explanation about lineweight 8246.pdf (159.3 KB). But I’m not sure this explanation fits your problem. In this case please create new forum branch with the question.

In order to use CTB file please put it near your drawing file and it should be processed automatically.

1 Like

Hello, what do you mean by? I’m loading my drawings from a memory stream

put it near your drawing file

Thank you for clarification. We’ve create related ticket CADNET-8556 to cover this case. Will be available on release 22.4

The issues you have found earlier (filed as CADNET-8556) have been fixed in this Aspose.CAD for .NET 22.4 update . This message was posted using Bugs notification tool by Oleksii.Gorokhovatskyi

1 Like

Example of usage:
CadRasterizationOptions rasterizationOptions = new CadRasterizationOptions();
string ctbFile = GetPath(“Hawa.ctb”);
rasterizationOptions.CtbSources = new Dictionary<string, Stream>();
rasterizationOptions.CtbSources.Add(“hawa.ctb”, File.OpenRead(ctbFile));

1 Like