Question on 11/4/4 release


#1

I have a question on the new release of 11/3/4, for which I am enclosing the zipped application, minus the license file (for security, in sending email). I think I had difficulty with outlook in sending the zipped file, so I will send it via my www.fastmail.fm account. Here is the issue:

1. In the new release, the old template is RandyPagersDraftOneSlide.ppt, for which the routine being executed is CreatePowerPointOneSlide(). To get this application to work without the database calls, comment the lines:
-----------------------------------------------------------------------------------------------------------------------------------------------------------

If countImagesFromDatabase(productKey, imageType) Then

'Dim sqlrdr2 As SqlDataReader = GetProductImage(productKey, imageType)

'Dim stream2 As MemoryStream = New MemoryStream(CType(sqlrdr2, Byte()))

Dim picid As Integer = pres.Pictures.Add(New Picture(pres, GetImageFromDatabase(productKey, imageType)))

pf.PictureId = picid

Else

Endif

---------------------------------------------------------------------------------------------------------------------------------------

This will then product the image with the 11/3 release. The problem is that the text “V810 Key Product Features” in red and the text “TT w/ Camera (name TBD)” both appear. If I use the prior release, this doesn’t happen. Is this a bug in the new release, and if not, is their a way to not have the text “tt w/Camera (Name TBD)” NOT display, but be present, like in the template slide? Thanks.


#2

Dear Randy,

Problem with text color was fixed in the new 1.3.7 hot fix.


#3

Alex:
I tried the 11/5/4 1.3.7 release with time 3:33 PM, and still get the same issue. Under a seperate email, I will mail the application to you as a zipped file. The problem is not the color, but the text appearing.
If you look at the slide template, the text “V810 Key Product Features” is visible in red, but the black text “TT w/ Camera (name TBD)” isn’t. After I run it though the application, but texts appear in the final output. In the release numbered 1.3.5 and prior, this was not an issue, and the final power point slide appeared with the black text hidden. I didn’t change any code when I went from the 1.3.5 to the 1.3.6 (and now 1.3.7) releases. I hope this clairifies the issue, and either it (1) is a bug or (2) there is a new method or property I must set to keep the text “TT w/ Camera (name TBD)” hidden in the final slide, just it is was in the template - if so, then please let me know how to set it. Thanks.
Randy


#4

Let me add a bit more explanation. The slide template our users gave us appears to have a frame within a frame. If you go to the top of the template, you see the visible text “810 Key product Features”. Then if you click on the outer boundry, or do a search for the text “TBD” in Power Point, you see the other frame containing the text “TT w/Camera name TBD”. Now if I go back to the 1.3.5 release of 10/27/4, this text doesn’t appear in the final Apose Power Point generated slide, but is hidden in the background - like in the template frame. If if use release 1.3.6 +, both frames appear to be printed or generated together.


#5

Dear Randy,

Yes, “TT w/Camera …” is a white text on white background and it’s invisible.
1.3.6 and 1.3.7 replaced white color with black…

Please check 1.3.8 hot fix. I hope it will be ok now.
I tested it with your templates.


#6

Alex:
Everything is fine now. Thanks for the quick response. I will always do regression testing on our power point applications for each new release. If any issue comes up, I’ll post it here in the forums, and send you the slides, etc. Great response turnaround on problem resolution.
Randy