We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Cannot read a name from the name table in a font." error when trying to convert a Word doc to ePub

Hi,

I’m getting a “Cannot read a name from the name table in a font.” error when trying convert a Word 2010 file to ePub. I made modifications to a file I previously converted successfully, and now get that error. The entire error message is:

at x1924ed26840b3421.x4e846d09fe48634b(Boolean x29ca7772d281a736, String x1f25abf5fb75e795, String x9f15a273ba01f6f6)
at x6412d0c71c34c05c.xa8b3ec28bb8af623(Int32 xfdb30831d4bc44ed)
at x6412d0c71c34c05c.x0c269939c278bc2d(x25998da3963930e9 x0db5e88527e18b81)
at xe1f670dfbcd03c5c.x4c94e46bee37bf2d(x25998da3963930e9[] xffe132185f45c5fd)
at xe1f670dfbcd03c5c…ctor(x25998da3963930e9[] availableFontsData)

at x9d888f53892d94df.x34ef7a0ea5d7fab4()
at x9d888f53892d94df.get_x2445f4cefb3cff80()
at x9d888f53892d94df.xdc2247c8d4648ae8(String xa79a9f649c74f4a4, FontStyle x44ecfea61c937b8e)
at x26ee10d60756aeab.xdc2247c8d4648ae8(String xa79a9f649c74f4a4, FontStyle x44ecfea61c937b8e)
at x29ade4ed2382a039.xe42a11aae6b85740(String xa79a9f649c74f4a4, FontStyle x44ecfea61c937b8e, String x050683ee5a5f962b)
at x29ade4ed2382a039.x491f5a7224612753(String xa79a9f649c74f4a4, Single xdb421875a5f5258b, Boolean xb0c2ce71ea178326, Boolean xeac181883dccb27a)

at x3172fc8167520602.x10b9a8341517f825(xfdc1a17f479acc42 x41baca1d6c0c2e8e, x1a78664fa10a3755 x9e5248b49f0df7e8)
at x967f6fb76e7d0c72.VisitParagraphStart(xfdc1a17f479acc42 para)
at xf83a1096941de9f7.xf7ae36cd24e0b11c(x74a64277c8b38895 x672ff13faf031f3d)
at xf83a1096941de9f7.x464d2134480a7bf2(x74a64277c8b38895 x672ff13faf031f3d)
at xf83a1096941de9f7.xf7ae36cd24e0b11c(x74a64277c8b38895 x672ff13faf031f3d)
at x967f6fb76e7d0c72.x1e54fa3a59f86a2a(x555897a1eb70677c x721b2192f9b85c66)
at x967f6fb76e7d0c72.x51ee56decc29a9da(x10d7a1cae426b158 xb32f8dd719a105db)

at x967f6fb76e7d0c72.xd7560e2140c6338f()
at x967f6fb76e7d0c72.xe00a9c07c675b8ed()
at x967f6fb76e7d0c72.xa2e0b7f7da663553(x2c8c6741422a1298 x6beba47238e0ade6, Stream xcf18e5243f8d5fd3, String xafe2f3653ee64ebc, Boolean xddad811e564048f0, x1e7f349fdaeb4701 xc27f01f21f67608c,
IDictionary x82fcc4c2a16a6294)
at x75eb89ee42a8f635.xb0f465f5d9c363bb()
at x75eb89ee42a8f635.x8cac5adfe79bc025(x8556eed81191af11 x5ac1382edb7bf2c2)

at x2c8c6741422a1298.xf381a641001e6830(Stream xcf18e5243f8d5fd3, String xafe2f3653ee64ebc, xf57de0fd37d5e97d xc27f01f21f67608c)
at x2c8c6741422a1298.x0acd3c2012ea2ee8(String xafe2f3653ee64ebc, xf57de0fd37d5e97d xc27f01f21f67608c)
at xcf2e17f3c5d11fc4.x18dfca7c5fd2402f()
at x611834a0f7af5345.x18dfca7c5fd2402f()
at Control.OnClick(EventArgs e)
at Button.OnMouseUp(MouseEventArgs mevent)
at Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at Control.WndProc(Message& m)
at ButtonBase.WndProc(Message& m)
at Button.WndProc(Message& m)
at ControlNativeWindow.WndProc(Message& m)
at NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)

at ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at x867eb3246b182488.xc447809891322395()


Any suggestions? I tried downloading and installing the “latest version” of Aspose.Words.Express, but unzipping the contents shows the EXE to be from 07/02/2011 as opposed to the Aspose site stating it was uploaded 04/22/2013.

Any help you can give is welcome.

Pete


Hi Pete,

Thanks for your inquiry. Please note that Aspose.Words Express is a free utility and it uses Aspose.Words 10.2.0 version. Could you please attach your input Word document here for testing? I will investigate the issue on my side and provide you more information.

Hi Tahir,

Thanks for getting back to me on this issue. Strange that the conversion was working for me before, and is not now. I found the problem, and here is what I discovered:

I had numbered lists in the document, and these numbered lists were generated by Word’s Number List feature (the on on the Home tab under the Paragraph section. By half-stepping through the document (I created a copy and deleted half of the text, and then tried to convert the document again) I found that a chapter that had a numbered list, once the list was deleted, converted as it should.

I changed all my Word-controlled Numbered Lists into manually entered numbered lists (more of a pain for me to maintain!), and the entire document converted as it had before.

The "“name table in a font” title of the error is a “red herring” and the subsequent font references in the error message don’t help, either.

Hope that this explanation helps someone else. And, I suspect I would have had the same issue with automatic Bullet Lists, too. Please pass this on to your compatriots there at Asspose, and if you have a knowledge base, add this issue/solution to it.

Pete

Hi Pete,

Thanks for sharing the detail. It is nice to hear from you that you have solved your problem. I would suggest you please try the latest version of Aspose.Words for .NET v13.6.0 from here:
http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/entry478555.aspx

Moreover, please read how to convert MS Word document to ePub file from here:
http://www.aspose.com/docs/display/wordsnet/How-to+Convert+a+Document+to+EPUB

Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.


Thanks, Tahir. I’ll download the zip file and see if I can use that next time I need to create an ePub from a Word doc. I appreciate the support, and the links. (Or, should I say, merci! :slight_smile: )

Pete

Hi Pete,

Thanks for your feedback. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.