We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Excel found unreadbale" when using "Xlsx" format option

Hi,


We are having an issue right now when using OoxmlSaveOptions from Aspose.Cells.

We are receiving document repair message - “Excel found unreadable content…” when we try to save Excel file using “Xlsx” format options.

wb.Save(Page.Response, “Statements.xlsx”, ContentDisposition.Attachment, new OoxmlSaveOptions(SaveFormat.Xlsx))


but the exact same code works just fine if we use “Excel97To2003” format:

wb.Save(Page.Response, “Statements.xls”, ContentDisposition.Attachment, new OoxmlSaveOptions(SaveFormat.Excel97To2003));


As suggested in other posts we tried upgrading existing Aspose.Cell dll version - 7.3.4 to 8.0.2 but it hasn’t yet worked for us.

Please advise and let us know if you need any particular information.

Thanks,
Ana.




Hi Ana,

Thanks for your posting and using Aspose.Cells.

This issue could be because of some bug in Aspose.Cells. Please provide us your sample code and source file replicating this issue for our investigation. We will look into it and log it in our database so that this issue could be fixed.