Free Support Forum - aspose.com

"Fit Text" does not work on cell in word 2007

We have a cell in a table that could have text that would not fit into the cell, in the cell options I checked off “Fit Text”, and in word itself if I enter more text it will condense them, but Aspose does not, so it cuts out the last part of the text

Is there something I am missing?

Thanks in advance

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. If I understand you correctly, you mean “Auto-fit to content” option of a table cell. Unfortunately, there is no way to specify “Auto-fit to content” option of a table cell using Aspose.Words. I linked your request to the appropriate issue; you will be notified as soon as this feature is supported.

Currently, you can only specify fixed width of table cells.

Best regards,

It’s not fit to contents, it’s the other way around

In word, on a cell that has a preferred width, go to table properties/cell/options and check off “Fit Text” and look at the results

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I cannot reproduce the problem on my side using the latest version of Aspose.Words. Could you please also attach your input and output documents and expected output? I will investigate the issue and provide you more information.

Best regards,

Ok, here is the template and a file after getting the data in it trough Aspose words, in the column SKU, the text does not fit, so try to edit the data in word 2007, word will condense the data. But Aspose would not do it

<!–[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0pt 5.4pt 0pt 5.4pt; mso-para-margin:0pt; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

<![endif]–>

Hi

Thank you for additional information. I think, you should just specify height rule of the second row in your table to “At least” instead of “Exactly”. Please see the attached screenshot.

Hope this helps.

Best regards,

The issues you have found earlier (filed as WORDSNET-2044) have been fixed in this .NET update and in this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(28)