We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Font 'SansSerif' cannot be found." exception

Hi guys,


I’m getting an error with this specific ppt file when trying to save it as PDF.
This is the code I’m using:

using (var slide = new Presentation(sourceStream))
{
slide.Save(outputStream, SaveFormat.Pdf);
}

I tried using this LoadOptions class also but without any luck

var loadOptions = new LoadOptions(LoadFormat.Auto) {DefaultRegularFont = “Verdana”, DefaultAsianFont = “Verdana”};

When using a different output format (i.e. Pptx) it didn’t raise the exception but the problem is that I need to export to PDF only.

My environment is a vanilla Win7 installation (with all the fonts installed by default) and Aspose.Slides version 14.2.0.0.

Any suggestions???

Cheers!

PD: I tried to upload the file and I got a “404” error. Then I tried to share a OneDrive link to the file but I got a “only these file types are allow …” so let me know how I can share the file with you.

Hi,


Thanks for your interest in Aspose.Slides.

I have observed the requirement shared by you and request you to please share the sample code and sample presentation with us. I will investigate the issue further on my end to help you out.

Many Thanks,

Hi Mudassir, thanks for your answer.


I’ve been trying to upload the ppt but no luck so far. I got a 404 error everytime.

The ppt is 54Mb and the zip 51Mb. Is there any restriction is size for uploads??

I tried to share it with OneDrive but again, I’m getting an error regarding the type of file is not allowed. Do I have another option to give you the file?? like an email account or FTP ??

Hi,


I suggest you to please try using dropbox or other drives for sharing the files. You can also zip the files and share them via your FTP server. Aspose.Slides forums does not allow 50 MB file as attachment. Please share the requested information with us so that I may proceed further with my investigation.

Many Thanks,

Hi Mudassir,


Thanks for you message. Finally I could share the presentation with you.

Cheers.

Hi,

Thanks for sharing the presentation file. I have worked with presentation file shared and have exported that to PDF using Aspose.Slides for .NET 14.6.0 on my end. I have not observed the issue specified. Can you please try using the specified version on your end and share with us if there is any issue incurring.

Many Thanks,

Hi Mudassir,


Thanks for your message. I can confirm that everything works fine with the latest version.

Thanks again!