"Object reference not found" error with trial version of Aspose.Total

I downloaded the trial version of Aspose.Total for Sharepoint from this location:
http://www.aspose.com/community/files/73/sharepoint-components/aspose.total-for-sharepoint/entry278548.aspx

I installed it on our server that is running Sharepoint 2010. I tried the Convert via Aspose.Words on one of our documents and I’m experiencing the following problem:
on the Aspose.Words conversion settings (the one that appears after you click “Convert”), when I click “…” to browse for the destination folder, I get an error which after I looked it up in the Sharepoint log file is this:
“System.NullReferenceException: Object reference not set to an instance of an object. at Aspose.Words.SharePoint.Internals.BrowseDialog.豭(SPFolder غ)”
So I browsed in Windows Explorer to that BrowseDialog.aspx to look at that page and see what might be causing the error. At the top of the aspx it shows this:

<%@ Assembly Name=“Aspose.Words.SharePoint, Version=2.9.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56” %>
<%@ Assembly Name=“Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c” %>

Is this correct? It’s using Sharepoint version 12 (which is Sharepoint 2007)? Shouldn’t it say Sharepoint version 14? I’m not sure whether this is what’s causing the error but I know that in the past when we had some dlls defined in web.config and the version number was not correct we would get the “object reference” error message because it couldn’t find that dll. If that’s not the problem, then what’s causing this error?

thanks,

Hi Beata,


Thanks for your inquiry. Unfortunately, I was unable to reproduce this issue on my side; however, I have logged this issue in our bug tracking system for our development team to further look into the details of this problem. The ID of your issue is WORDSSP-224. Your request has also been linked to this issue and you will be notified as soon as it is resolved. Sorry for the inconvenience.

Best regards,

Hi Beata,


Thanks for your inquiry. It is to update you that we have recently published a new release of Aspose.Words for SharePoint i.e. 2.10.0 below:
http://www.aspose.com/community/files/73/sharepoint-components/aspose.words-for-sharepoint/entry494602.aspx

Could you please upgrade to the latest version and let us know how it goes on your side? I hope, this helps.

Best regards,