Free Support Forum - aspose.com

Random beeps with version 5.2.0

Greetings,


I upgraded my application to use Aspose.Slides 5.2.0 for .NET and I have found that the program now generates seemingly random beeps on the console. I rolled back to version 5.1.0 and the beeps went away. The only change I made is changing the reference from 5.1.0 to 5.2.0, so I believe the beeps are attributable to the new version of Aspose.Slides. I have not been able to isolate what call is causing the beeps and it would not be practical to post my entire source code here. I hope the Aspose developers can find a place in the code where the beep may be being called.

thank you,

mz

Hi Erik,

I have worked with Aspose.Slides for .NET 5.2.0 and unfortunately I have not been able to reproduce the issue specified. It will be really convenient if you may please share the code snippet for necessary investigation. I have created an issue with ID 27444 as investigation in our issue tracking system to investigate the issue. This thread has also been linked with the issue so that you may be automatically notified once the issue is resolved.

We are sorry for your inconvenience,

Hello Mudassir,


I have isolated the call that triggers the beep. The call is sl.GetThumbnail(1.0F, 1.0F) where sl is an Aspose.Slides.Pptx.SlidesEx object. Every slide in the attached pptx will trigger one or more beeps on my system (Win 7 64-bit system, executable uses .NET 4, Aspose.Slides 5.2.0 .NET 2.0 32-bit). This is built as a console application.

These slides all raise the following exception:
System.NullReferenceException: Object reference not set to an instance of an object.
at Aspose.Slides.Pptx.ChartEx.(Boolean bNew)
at Aspose.Slides.Pptx.ChartEx. canvas, ? rc)
at Aspose.Slides.Pptx.GroupShapeEx.? canvas, ? rc)

With Aspose.Slides 5.1.0 I get the following exception, but do not hear the beep:
System.NullReferenceException: Object reference not set to an instance of an object.
at Aspose.Slides.Pptx.ChartEx.b(Boolean a)
at Aspose.Slides.Pptx.ChartEx.Draw(aza canvas, lu rc)
at Aspose.Slides.Pptx.GroupShapeEx.Draw(aza canvas, lu rc)

I hope this helps track down the issue.

Thanks,

mz

Hi Erik,

I have worked with the presentation file shared by you and have been able to observe the issue shared by you. I have also observed the exception while generating the slide thumbnail. The issue description for 27444 has also been modified. We will share the further information with you once it is shared by our development team.

Thanks and Regards,

The issues you have found earlier (filed as 27444) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.