We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Reading Series Name from Waterfall Chart

When Reading the Series name from my waterfall chart it has the wrong name:

2020-06-24 07_20_18-AsposePlay2 (Debugging) - Microsoft Visual Studio.png (37.9 KB)

In excel the series name is 2020-06-24 07_21_15-ChartExamples.xlsx - Excel.png (10.1 KB)

Is this a bug or am I reading the series name through the wrong property

seriesName = chart.NSeries[i].Name

@mallain2323,

Please zip your template file and attach it, we will check it soon.

ChartExamples.zip (50.1 KB)

Excel file attached - you will see it has many charts using same series - but Waterfall chart only one giving me the issue

@mallain2323,
We have observed this issue and logged it for further investigation. We will write back here once any feedback is ready to share.

CELLSNET-47444 - Wrong series name read from Waterfall chart

@mallain2323,

This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@mallain2323,
Please try our latest version/fix: Aspose.Cells for .NET v20.6.4:

Aspose.Cells20.6.4 For .Net2_AuthenticodeSigned.Zip (5.4 MB)
Aspose.Cells20.6.4 For .Net4.0.Zip (5.4 MB)

Your issue should be fixed in it.

Let us know your feedback.

@mallain2323,
The issues you have found earlier (filed as CELLSNET-47429) have been fixed in Aspose.Cells for .NET v20.7. This message was posted using Bugs notification tool by ahsaniqbalsidiqui

After updating to 20.7.0 (from 20.4.0) I cannot create a Workbook from a memory stream with an excel file with a waterfall chart in it (there is a null reference error) I have uploaded the error, code that errors out and the file -ChartExamples.zip (50.1 KB)

error.zip (72.2 KB)
2020-07-15 22_48_31-TackleBox (Debugging) - Microsoft Visual Studio.zip (19.6 KB)

@mallain2323,
We have tried to reproduce this issue here but could not succeed. Could you please share a runnable console application which can be compiled and executed here for our analysis?

I am still having issues with this - can you use the files that I attached to recreate the error — the only code that you need after this is new Workbook() with the memory stream from the file. This was not an issue BEFORE your fix in earlier versions - this was a result of the fix in 20.6.4:

@mallain2323,
I tried again to reproduce it but issue is not occurring on my end. Please create a runnable console application for our analysis.