We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Receive Error when trying to run Aspose.Cells.Demos

I am running Windows XP with SP3 and VS2005 and VS2008. I also have TFS 2008 client. I recived some error messages during installation of the Editor component, but none during Cells install. I have done a repair and a re-boot.

Server Error in '/Aspose.Cells.Demos' Application.

Could not load file or assembly 'Aspose.Cells, Version=4.4.3.1, Culture=neutral, PublicKeyToken=716fcc553a201e56' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Aspose.Cells, Version=4.4.3.1, Culture=neutral, PublicKeyToken=716fcc553a201e56' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Aspose.Cells, Version=4.4.3.1, Culture=neutral, PublicKeyToken=716fcc553a201e56' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Stack Trace:

[FileLoadException: Could not load file or assembly 'Aspose.Cells, Version=4.4.3.1, Culture=neutral, PublicKeyToken=716fcc553a201e56' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)]
   Aspose.Cells.Demos.Global.Session_Start(Object sender, EventArgs e) +0
   System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e) +2221711
   System.Web.SessionState.SessionStateModule.CompleteAcquireState() +159
   System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData) +518
   System.Web.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +90
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +161


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

Hi,

Is the installation process worked fine and Aspose.Cells component is installed correctly on the pc. Tell us does the exception you have mentioned occur when you run Aspose.Cells Demos? It seems that you try to add reference to 4.4.3.1 fix and got the error. Could you give us more details and give info that which Aspose.Cells version (official release) you have intalled on your machine.

By the way did you try to install our latest version 4.5 and check if its demos run fine: http://www.aspose.com/community/files/51/file-format-components/aspose.cells/entry133353.aspx

Thank you.

Amjad, I just downloaded the install yesterday. The timestemp on the Aspose.Cells.msi is 6/27/2008 at 1:32 am. The error page that I sent was from the Aspose.Cells demo. Also, I tried the WinForms demo and that seems to work. Let me know what othe information you may need.

Hi,

Well, I tried the demos and they worked fine. Could you download Aspose.Cells.msi installer separatedly : http://www.aspose.com/community/files/51/file-format-components/aspose.cells/entry133353.aspx and intall it separatedly (you should uninstall the previous first). Well, I tried the demos, I did manually browse the folder i.e.., ....\Program Files\Aspose\Aspose.Cells\Demos\Aspose.Cells.Demos and ran the Aspose.Cells.Demos project file, it was firstly converted to vs.net 2005 compliance and later I did run (F5) the same project, everything was just fine. By the way the demos should include 4.5.0.0 version of Aspose.Cells and not 4.4.3.1 fix.

Thank you.

Amjad, when I saw your instructions, I realized the difference. You are building and running the demo from VS2005. I was just installing the demo and running. When you do this there are two (2) problems. First, the menu shortcut URL for the Cells demo does not specify Default.aspx and the web site created by the install does not have “Enable Default Document” on the “Documents” tab set to “Default.aspx”. Second, the demo still does not run (Even after manually removing and reinstalling the “Aspose.Cells.msi” from the URL you provided). Opening and compiling the project fixes the problem. I can now run from “http://localhost/Aspose.Cells.Demos/Default.aspx” and the VS2005 project runs from within VS2005. You may want to test the “Aspose.Cells.msi” install on a clean machine and try just running the demo without opening and compiling in VS2005. Anyway, thank you for your help. It looks like its working now.

Speaking of VS2005 have you tried to open several of the forms in designer mode? I get errors about various mismatching tags () etc. Also, when I generate a spreadsheet I get prompted with the File Download confirmation for “FinancialPlan.xls” which is correct, but the Excel complains that the extension does not match the expected type, specifying “The file you are tying to open, ‘BusinessReports.aspx’, is in a different format then specified by the file extension. Verify that the file is not corrupted…”. I am guessing that the Response.ContentType or the “Content-Disposition” heder entries are incorrect. I don’t mean to be nit picky, but I am evaluating your software for my company and if the demos are not correct, what does that say about the code for your controls?

Hi,

Thanks for sharing some details about demos,

Well, actually we have a very busy schedule, we are always busy in developing features and enhancing the existing features related component's APIs, providing customer support and providing them with most updated documentation for the component : http://www.aspose.com/documentation/file-format-components/aspose.cells-for-.net-and-java/index.html all the time. Aspose.Cells has a long list of features (standard, valuable and advanced features set), it provides as many featues as MS Excel does. Furthermore we also do provide some customer specific feature APIs which MS Excel does not provide. It looks that demos might be neglected a bit. Actually there are a few older demos in Aspose.Cells.Demos set (featured demos packaged in Aspose.Cells msi installer), these are originally developed in VS.NET 2002 (.net framework 1.x) which might cause some issues. Anyways we will look into it and fix it soon.

For "FinancialPlan.xls" spreadsheet issue, the code is referring some old style(e.g., The info error occurs if you have installed Excel 2007 on you pc), so you may change the saving line of code to: e.g..,

workbook.Save("FinancialPlan.xls",FileFormatType.Default,SaveType.OpenInExcel,System.Web.HttpContext.Current.Response);

Thank you.

Amjad, I made the change you suggested and it works great. Thanks for the quick response. As for my previous post, I wasn’t trying to be nasty, more that I was trying to emphasize that for some developers (my self included), the demos are the “first impression” of your software. And as the old adage goes, “You never get a second chance to make a first impression” :slight_smile: Thanks again!