Receiving "Unsupported brush type." error

When you start up powerpoint 2007 and use one of the templates called "Introducing PowerPoint 2007", save that to PPTX - and then try to convert and it throws this error.

1) is there a way to suppress this and have it still try to convert?

2) are you going to add support for this?

we are still using Slides 5.7.0.0 - perhaps this was fixed in 6.1.0.0?

Tried 6.1.0.0 and the error still occurs

Hi Tom,


Thanks for your interest in Aspose.Slides.

I have tried to understand the issue shared by you and have not been able to reproduce the issue while accessing and converting your shared presentation to PDF. Can you please share the sample presentation causing the issue along with the code snippet that you have used on your end to reproduce the issue. I have used Aspose.Slides for .NET 6.1.0.

Many Thanks,

Mudassir -


Thanks for getting back so quickly, we have done some additional diagnosis and we have identified this is occurring not with the save to PDF function, but when we save to XPS.

can you try again on your side and see if that happens?

Hi Tom,


I have worked with the presentation file shared by you and have been able to observe the exception shared while generating XPS image. An issue with ID SLIDESNET-33407 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

Many Thanks,