Free Support Forum - aspose.com

Regression curved lines

Regarding the DIAGRAMNET-51693 issue there seem to be a regression regarding curved lines in 19.9 from 19.8

Attached is outfiles, source file in on the DIAGRAMNET-51693 issue
Version 19.9 (single page) single_page_msd19120.vsd.pdf (810.8 KB)
Version 19.9 (multiple pages)msd19120.vsd.pdf (4.4 MB)
Version 19.8 (single page)msd19120.pdf (852.7 KB)

@hellagutmanndk

A separate issue as DIAGRAMNET-51718 has been logged in our issue tracking system for this case. We will surely look into details of it and keep you posted with the status of its rectification. Please be patient and spare us little time.

We are sorry for the inconvenience.

@hellagutmanndk

We were unable to notice any issue using Aspose.Diagram for .NET 19.9. Please check attached screenshot. Would you kindly share the screenshot of the issue you are facing at your side.

51718.png (2.2 KB)

These are the lines that have regressed. Left side is from 19.9 and right side is from 19.8 (black circle around one of them)

203453_31238.png (48.8 KB)

hellagutmanndk

Please check attached PDF which was generated in our environment using Aspose.Diagram for .NET 19.9 and we were unable to find any issue in it. We used following code snippet:

Aspose.Diagram.Diagram diagram = new Aspose.Diagram.Diagram(dataDir + "msd19120.vsd");
Aspose.Diagram.Saving.PdfSaveOptions pdfSaveOptions = new Diagram.Saving.PdfSaveOptions();
diagram.Save(dataDir + "msd19120.pdf", pdfSaveOptions);

51693.pdf (852.4 KB)

Would you kindly highlight if you are able to notice any issue in attached PDF. We will again check it in our environment as per your feedback.

that looks fine, I am going to try a conversion again. I will get back with the results shortly

So did some further testing. And based on experience i tried running the test app on the machine which does the work normally, and that worked, the i tried changing the region of my windows 10 machine from Denmark to Australia, and that did the trick.

I then changed back to Denmark, and now it still works. Apparently there were some settings that changed in that region change, which make the Denmark region work correctly.

So please close the ticket - and take a note about this region stuff. I am not sure you could have foreseen it, or make change to the code to fix it.

I also tried setting the Culture of the thread with no luck.

@hellagutmanndk

Thanks for the feedback.

We have updated the ticket information by logging your feedback there and will take care of these concerns. In case you need further assistance, please feel free to let us know.