Free Support Forum - aspose.com

Removing the Evaluation watermark in SSRS extensions

I have recently purchased and downloaded a Custom Licence for various SSRS rendering extensions. I ran the msi installers and copied the aspose.custom.lic file to the bin directory as instructed (C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\bin), however I still get the evaluation watermark displayed when I run the report.

Any ideas why this is not working?

Hello,

My name is Danny Cooper and I am with the business side of Aspose. Thank you for your purchase and I am sorry to hear about your troubles. I visited with our web team a moment ago and it appears that there is an error in the way your license is generated. The web team is working to correct this issue and will reply once it has been resolved (that should be within a few hours). Please be sure to let me know if there is any other way that I can help during the interim and I will be more than glad to.

Hello,

I have corrected the license file and it has been emailed to you. Please let us know if you have any more problems and I will be happy to help.

I have copied in the new licence file you sent me and I am STILL getting the same problem with the Eval watermark in Word, pdf etc. The only one that works correctly is Excel 2007

I will forward this to the Team Leaders involved. Expect a reply shortly.

If you rename the license file to “Aspose.Pdf.Reporting.Services.lic” or “Aspose.Total.ReportingServices.lic”, it will work for Aspose.Pdf for Reporting Services. Sorry we have not made this clear in the documentation.

OK, I have followed your instructions and copied and renamed the licence file you sent me (Aspose.Custom.lic). I now have a licence file for each of the products I purchased (5 licence files):

Aspose.Barcode.ReportingServices.lic

Aspose.Cells.ReportingServices.lic

Aspose.Pdf.ReportingServices.lic

Aspose.Slides.ReportingServices.lic

Aspose.Words.ReportingServices.lic

The Eval watermark has now been removed from all extensions EXCEPT the Excel Workbook (XLS) extension (the Excel 2007 extension works correctly). Is there something missing from the licence file?

Let me know if you want me to send you the licence file

alifin:
I have copied in the new license file you sent me and I am STILL getting the same problem with the Eval watermark in Word, pdf etc. The only one that works correctly is Excel 2007

Hello Alifin,

In one of your earlier post you said that the Excel 2007 was the only app worked correctly. Perhaps instead of creating the Aspose.Cells.ReportingServices.lic you could also keep one named how it was original. Please let me know if you need any thing else and I will be more than happy to help.

Alifin,

Please check your email. I have sent new license files to you.

Copied the new licence files over and still getting an Eval watermark in the XLS extension. I have attached some screen shots to show what I am doing

Hi alifin,

Please try this fix.

Please copy Aspose.Cells.Reporting.Services.lic to the License directory (C:\Program Files\Aspose\Aspose.Cells.ReportingServices\License).

Copied licence file into directory as requested, but I still have the same problem. Please see the screen shots attached to my previous reply. It looks to me like the code that is running to create the spreadsheet either is not looking for a licence file or is looking in the wrong place. The server where the ASPOSE products are installed runs Windows Server 2003, Visual Studio 2005 and SQL Server 2005, with all the latest updates applied. The client machines that will run the reports run a mixture of Office 97 / 2003 / 2007

Please provide some infos.

---------------------------------------------------------------------------------------------

  • Open registry Editor.
  • Find and open the "HKEY_LOCAL_MACHINE\SOFTWARE\Aspose\Aspose.Cells.ReportingServices" key.
  • Get the value of "Path".
  • The licence file = the value + "License\Aspose.Cells.Reporting.Services.lic".
  • Find the file.
  • If it can not find the file , it get the evaluation watermark.

------------------------------------------------------------------------------------------------

Please post install.log here

I have checked my registry and I don't have an entry for ASPOSE anywhere in the registry.

Also looked for the install.log file and couldn't find one for ASPOSE on the drive where ASPOSE and SQL Server is installed. The only files called install.log related to Oracle and Veritas

Hi,

Thanks for your further info,

We will check your issue soon.

Thanks for being patient!

Hi alifin,

Please try this fix.

----------------------------------User Actions---------------------------------

  • Uninstall old version and install this fix.
  • Rename the licence filename to Aspose.Cells.Reporting.Services.lic . Please note capitalization.
  • Copy it to the licence folder($[installation folder]/Licence/).

--------------------------------------------------------------------------------

If the problem persists , please according infos.xls fill out info.

Thanks very much. That has fixed my problem with the XLS extension. My final issue is with Barcode. When I design a report that includes a barcode what looks like a watermark also appears - the word ‘Aspose’ is inserted next to the barcode. This shows when I develop and when I deploy the report. I have attached a screen shot

Hello,

Could you please send me your license file? I will help to debug the issue.

My mail box is guangzhou$$aspose.com (replace the $$ to @).

Thanks,

I sent my licence file through to you on the 21st April, but haven't heard anything since. Did you receive it?

Thanks

Alistair

Hello, Alistair,

Please try the latest version of Aspose.BarCode, thanks.

Best regards,