We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Rendering PDF from Excel ignores Alpha

I’m sorry, I attached wrong xls.
Here is the right one.

Hi,

Thanks for providing the right file…

After
initial investigation, we were able to observe this issue with the
latest version. We have logged this issue in our database. We will look
into it and resolve it. Once, the issue is fixed or we have some other
update relating to it for you, we will let you know asap.

This issue has been logged as CELLSNET-41566.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.2.5 and let us know your feedback.

Hi,

I tested new version and the fix worked.
Thanks a lot.

Hi,

Thanks for your feedback.

Good to know that your issue is resolved with the latest version.

Feel free to contact us any time if you need further help or have some other query, we will be happy to you help you more.

The issues you have found earlier (filed as CELLSNET-41566) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hi,

(still) after updating from 7.4.0.0 to 7.4.3.0 yesterday, our customer’s digital signature is loosing it’s transparency when saved as PDF (see attached hardcopies). Also, when saving as PDF the calculations get lost and “#value!” is shown. When NOT saved as PDF, everything works fine! Can you help me?

Thanks, Ingo

Hi Ingo,


Please attach your template Excel file here, we will check your issue soon.

Thank you.

File attached.

Thank you!

Hi,

Thanks for your posting and using Aspose.Cells.

We have found your transparency issue with signature. However, your other issue relating to L15 converting to #value does not exist. We have logged your issue in our database. We will look into it and resolve this issue. Once the issue is resolved or we have some other update for you, we will let you know asap.

We have tested your issue with the latest version: Aspose.Cells
for .NET v7.4.3.2
. We have also attached the output pdf for your reference.

This issue has been logged as CELLSNET-41690.

Hi Shakeel,

I installed v7.4.3.2 and the “not calculating” issue still exists, it’s reproducable. I don’t know what to do, the only difference is the “save as pdf”. You can have a look via TeamViewer or so, if that helps.

Thanks for your support
Ingo

Hi,

Thanks for your posting and using Aspose.Cells.

Please provide us your sample code replicating this issue with the latest version. We will look into your issue and help you asap. Please also provide us your output pdf file which you are generating with the latest version. Please make sure you are using the latest dll.

That’s about all we do (with dll v7.4.3.2):

Workbook workbook = new Workbook(_excelTemplateFileName);
Worksheet worksheet = workbook.Worksheets[0];

FindOptions findOptions = new FindOptions
{
SearchNext = true,
SeachOrderByRows = true,
LookInType = LookInType.Values,
LookAtType = LookAtType.StartWith
};

IDataReader dataReader = GetData();
Cell cell = worksheet.Cells.Find("#", null, findOptions);
while (dataReader.Read() && cell != null)
{
cell.PutValue(dataReader[“Id”]);

Style style = cell.GetStyle();
style.Font.Size = 12;
cell.SetStyle(style);

cell = worksheet.Cells.Find("#", cell, findOptions);
}

workbook.Save(_destinationFileName, SaveFormat.Pdf);

Hi,

Thanks for your posting and using Aspose.Cells.

Please try Workbook.CalculateFormula() method before saving the workbook into pdf format. If the problem still occurs, please provide us your runnable code to look into this issue.

Not very intuitive, maybe that’s worth being mentioned (e. g. here: http://www.aspose.com/docs/display/cellsnet/Convert+an+XLS+File+to+PDF+Format), but that did the trick - thanks! :slight_smile:

So we wait for a solution for the transparency issue.

Thank you
Ingo

Hi,

Thanks for your posting and using Aspose.Cells.

It’s good to know that your issue is resolved. Once, we have any update relating to transparency issue, we will let you know asap.

Hi Shakeel,

is there any news concerning the transparency issue? We need to keep a given layout so I can’t work around it.

Kind regards
Ingo

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We are afraid, there is no update for you at this moment. We have checked your issue status. It is still under process. Once, we will have some update for you, we will let you know asap.

However, we have logged your comment in our database against this issue.

Hi Ingo,


Thank you for your patience with us.

We have resolved the ticket logged earlier as CELLSNET-41690. Please try the new fix release Aspose.Cells for .NET 8.2.2.1 (attached), and let us know of your feedback.

The issues you have found earlier (filed as CELLSNET-41690) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.