Report created with earlier version will not open


#1

When trying to open the attached report which was created with an earlier version of Aspose, the file is not created and the error included in the zip file is generated. I’ve tried to open the report and re-publish it but am not able to do that because of errors that are generated. Below is a sample of an error.

Process(1) ASPOSE Alert : : Monday, July 8, 2019 2:52:11 PM : The Value expression for the textrun ‘D01Main_1_14.Paragraphs[0].TextRuns[0]’ contains an error: [BC30201] Expression expected.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Aspose.Cells.ReportingServices.Services.ReportingService.ReportingService2005.CreateReport(String Report, String Parent, Boolean Overwrite, Byte[] Definition, Property[] Properties)
at .(String , String , Boolean , Byte[] , )
at . ()

Contract Update Report.zip (21.6 KB)


#2

There seems to be a problem with dynamic formulas. I’ve tried recreating the report and it works until anything other than a simple dynamic formula is used.

&=&=L{r} works
but
&=&=L{r}/(1-P{r}) or even &=&=L{r}/P{r} creates the error - The Value expression for the textrun ‘D01main_1_14.Paragraphs[0].TextRuns[0]’ contains an error: [BC30201] Expression expected in the log.

I’m on version 19.5.0.0


#3

@berlblack,

Thanks for the sample RDL file and screenshot.

I have logged a ticket with an id “CELLSRS-559” for your issue. We will investigate your issue and try to figure it out soon.

Once we have an update on it, we will let you know.