We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Reporting Services: watermark message occasionally appearing on the PPT

Hello,

We use aspose.slides for reporting services (developer license).
Recently we migrated from a WIN2008 server / SQL2008 to to a new WIN2012R2 / SQL2014 platform.

Now we suffer from a watermark message occasionally appearing on the PPT. Only with subscriptions.
What might be causing the watermark?

Thanks,
Ivan

Hi Ivan,

I have observed your requirements and request you to please share the directory path location of where Aspose.Slides for Reporting Services license is placed along with information about version of Aspose.Slides for Reporting Services used on your end.

Many Thanks,

Mudassir Fayyaz

Hi,

Thank you for your response.

D:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportServer\bin

If I’m right it is version 2.2

Kind regards,
Ivan

@Ivandd

I have observed that you are using fairly old version. I suggest you to please try using Aspose.Slides for Reporting Services 17.5 on your end. The possible cause of issue may be some antivirus or other process which may temporary block access to license file or location where license file is placed. Can you please verify this on your end.

Many Thanks,

Mudassir Fayyaz

Hi,
Where can I find this version?
Antivirus is not an issue, the license is on the server where reporting services is running.

Kind regards,
Ivan

@Ivandd,

You may please download the specified version from this download link.

Many Thanks,

Mudassir Fayyaz

Hello,

We installed version 17.5 as suggested in the beginning of August.
We’ve been running daily SSRS subscriptions since then and everything has been working fine until recently the watermark re-appeared again…

What’s the next step in solving this issue?

Thanks!
Best regards

@Ivandd,

Can you please share the generated PPT and PPTX presentations with watermark on your end so that I may observe them for possible font file location. Even, if font file is placed on correct position, there is possibility that access to font file is not possible which is resulting in appearance of watermark ( If license is valid). Please make sure about access rights on your end or at-least try using an administrator account for testing purpose.

@Ivandd,

I have observed the presentation file shared by you and suggest you to please refer to slide notes, where you will find information that where Aspose.Slides expects license file along with license file name on your machine. Please make sure that license file with valid name is available on locations mentioned in slide comments. Please also make sure that you have access to license file on your machine as well and suggest you to please try using administrator account.

Hello,

Thank you for the quick reply.
I already noticed the notes part of the slide and I can tell you that the filename that is mentioned in the notes is indeed different from the actual file name.
The fact however is that we didn’t make any recent changes to the license file name, yet it has been running fine (without watermark) for 2 months. So, sure I can modify the filename, but I’m not convinced that it will prevent the problem from returning.

Do you have other suggestions?

Also, can you please remove the screenshot you uploaded to imgur. I don’t think it’s the intention that our internal company data is shared publically on the internet, without out permission…

Thanks!

@Ivandd,

Please accept my apologies for image upload. I have requested the imgur to remove the image from their site. As far issue related to license is concerned, as shared earlier that You may please need to have license file as mentioned in snapshot image shared earlier. Secondly, even if a valid license file is placed at valid path then still you need to make sure that if that license file is accessible by account you are using to render report. That is why I requested you to please try Administrative privileges account on your end to render report and see if the license is accessible.