We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

RTF Backgroundcolor

Hi,



when I convert a RTF file with a backgroundcolor to HTML, the color information get lost. What could be the reason for that behaviour?

In use is Aspose Words 14.9.0.0 with Mono 3.10.0 on MacOSX 10.9.5 which works well in general.

I attached a demo file.



Thanks in advance,



Malte Steiner

Hi Malte,


Thanks for your inquiry. I am afraid, there is no background color applied to the attached document (colorBackground.rtf). Please see attached screenshot which is taken with MS Word 2013 on my side. Please make sure that you have attached the correct document you’re getting this problem with.

Best regards,

Hello,

thanks for your assistance. Its indeed the right file, try to open on Windows in the WordPad application instead of the full grown Word and you should seen a green background.

Cheers,

Malte

Hi Malte,

Thanks for your inquiry. I tested the scenario and have managed to reproduce the same problem on my side. For the sake of correction, I have logged this problem in our issue tracking system as WORDSNET-10948. We will further look into the details of this problem and keep you updated on the status of correction. We apologize for your inconvenience.

Best regards,

Hi Malte,


Thanks for being patient. The background gets lost because when importing to RTF, Document.ViewOptions.DisplayBackgroundShape option is not set to True value. When opening colorBackground.rtf in MS Word 2013 background is lost too. If in colorBackground.rtf file, you set background using MS Word 2013 then this file is imported correctly. So, we can suggest you to set Document.ViewOptions.DisplayBackgroundShape to True. I hope, this helps.

Best regards,

Hi Malte,


Regarding WORDSNET-10948, our development team has completed the work on your issue and has come to a conclusion that they won’t be able to implement the fix to your issue. Your issue (WORDSNET-10948) is now closed with ‘Won’t Fix’ resolution. Please see the workaround in my previous post.

Best regards,