Free Support Forum - aspose.com

RTF to DOCX conversion losing images

I am evaluating Aspose.Words v11.6.0.0 with the purpose of converting RTF into DOCX. In the converted document, the images are missing. I've attached a sample RTF file, plus the DOCX file created by loading the RTF into Word 2010 and saving as DOCX from there (images are included), plus the DOCX file created by Aspose.Words by loading the RTF and calling Document.Save with the SaveFormat.Docx (images are not included).

Any suggestions on how to get the images into the docx?

Hi David,

Thanks for your query. It would be great if you please share some more information about your issue. I can see the image in both output docx files.

I’ve attached a Word docx containing screenshots of what I get for the two docx files sent in the initial post. Is there something you have configured in Word that lets you see the image in the Aspose-generated file? I don’t see the image, and it doesn’t print either, nor does it appear in the PDF file (also attached here) when Aspose is used to save the RTF to PDF format.

Hi David,

Thanks for sharing the details. I have managed to reproduce the same issue at my side. I have logged this issue as WORDSNET-6828 in our issue tracking system. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi,

I have the same problem. RTF to DOC conversion doesn't work as well for images included in RTF.

Do you have an idea when the problem could be solved ?

Thanks for you response.

Hi Stephane,

Thanks for your query. Unfortunately, this issue WORDSNET-6828 is not resolved yet. Currently, this issue is under analysis phase. I am afraid, I can’t provide you any reliable estimate at the moment. We will update you via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi Tahir. I’ve been researching this more and have determined that the problem is that there places where hidden text is used in the document and when a new group is started after the group with hidden text ( ‘{’ ) the \v state is not returned to the \v0 condition. Other previous modifiers such as \b for bold do get reset automatically when a new group is started. I’m able to get my images to come out by explicitly inserting \v0 before {*\shppict{\pict{… Hopefully you’ll be able to change this in the next build. We would like to be able to use your product without hacking the rtf stream.

Hi David,

It is nice to hear from you that you have solved your problem by a workaround. I like to share with you that this issue has been resolved. The fix will be available in next release of Aspose.Words (at the end of September 2012).

We appreciate your patience.

The issues you have found earlier (filed as WORDSNET-6828) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Version 11.8 solves this problem for us. We can now move forward in using Aspose as the solution in our product. Thanks for the timely fix.

Hi David,

Thanks for your feedback. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.