'Save As' when open in a web browser


#1

Hello,

I am evaluating Aspose.Cells and have a question. I have built a sample application that fills out an excel sheet and launches it in a separate window. I have tried both 'OpenInExcel' and 'OpenInBrowser' options, and they both result in opening in a browser, though 'OpenInExcel' does give me the option to save before opening it.. But after it is open in the browser, I would like to do a 'save as' on the excel sheet. I tried clicking the disk icon in the toolbar, but nothing happens. Is this a restriction of the trial version?

Thank you.


#2

Which version of IE are you using? What happens if you select "File"->"Save as" in IE?

Could you post your sample application here? Could you also post a screenshot of your web page when click the disk icon? Thanks.


#3

I realized that when I select 'Save As' in the web browser, it does save the excel sheet. I was thrown off by the fact that the default filename it gives is the name of the web page, which in my case is 'webform1.aspx', so I thought it was saving an html file. But is there a way to make the default 'Save As' file name as the one specified in my excel.save() command?

Thanks!


#4

Other users had also asked about changing the default 'save as' file name. Unfoturnately we don't have a solution for this issue for it's handled by IE.

By the way, when you use OpenInExcel option, is the Excel file still opened in your IE?


#5

Laurence,

Yes, it still opens up in IE even though I specify OpenInExcel. Do you know how to make it launch Excel? I'm using IE 6.0.2900.2180 in XP Pro SP2. Also, I have MS Excel 2000 installed.

Thank you,

Lanny Smith


#6

Hi Lanny,

It seems that there are some problems in your machine. Do you install all windows patches?

Please try the following piece of code to see if the file is opened in your Excel:

FileStream fs1 = new FileStream("d:\\book1.xls", FileMode.Open, FileAccess.Read);
byte[] data1 = new byte[fs1.Length];
fs1.Read(data1, 0, data1.Length);


this.Response.ContentType = "application/xls";
Response.AddHeader( "content-disposition","attachment; filename=book1.xls");
Response.BinaryWrite(data1);
Response.End();

This piece of code can show that this problem is not caused by Aspose.Cells. As I know, the solution is to install all windows patches.