Free Support Forum - aspose.com

Save Method not working correctly when riunning under https://

When I try to save the workbook to the Http Respone and the site is running under https:// the file download does not function. I verified that it was not specific to my code by running the Aspose.Cells.Demo under https:// and observed the same behavior. The download works correctly if the site is run under http://.

Does Aspose have a work around or a setting to handle sites running under https://?

Thanks,

Tim

Hi Tim,

Please check http://www.aspose.com/Wiki/default.aspx/Aspose.Cells/HttpsSsl.html .

Thanks for the response. I was able to make tat solution work for the FileFormatType.Default type but when I try it with CSV as the type it does not download anything. I have tried several different content types in hopes that was the issue, but none I tried worked correctly. If you can provide any insight into a solution for CSV downloads it would be much appreciated.

Please try:

response.ContentType = "application/csv";

I tried to set the contentType to "application/csv" and that did not solve the problem. No download box appears and there when I execute the code, however the system works fine when I try to download the excel file. Any more suggestions would be a big help as this was one of the reason we purchased Aspose.

What about “application/txt” or “application/vnd.ms-excel”?

response.ContentType = "application/vnd.ms-excel";

response.AddHeader( "content-disposition","attachment; filename=mydata.csv");

I was able to figure this out. It wasn't the response headers or content type that was the issue. The real issue was on the save to stream. If I pass CSV as the format to the Aspose save method it can't dowload it. Are you aware of this issue? Should this be able to be handled by the Save method? I would like to understand why this happens so we can avoid it when we integrate with other Aspose products such as PDF and Word.

Thanks,

Tim

Yes. This may be to root of problem. Please try this attached fix.