We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

SaveDate not updating

Hello


I have a MS Word file which contains a saveDate field, this field however is never updated when I edit and save this document with Aspose.Words.

Is the MS Word field saveDate supported by Aspose.Words?
I tried saving multiple times combined with the UpdateFields() method, but no success.

I found a similar thread:
SaveDate field does not update when Aspose.Words saves the document
which has a tracking-id WORDSNET-7912 what is the status of this ‘bug’?


Hi Max,


Thanks for your inquiry. Unfortunately, WORDSNET-7912 is not resolved yet. Your thread has also been linked to the appropriate issue and you will be notified via this thread as soon as it is resolved. Sorry for the inconvenience.

Best regards,

In the meantime I tried a couple other things…

I found out I could change the documentproperties. I have now added the following just before I save the document which results in an updated savedate field:

doc.BuiltInDocumentProperties.LastSavedTime = DateTime.Now;

I would say this property should be set automatically when saving, but this works for me too.

Hi Max,


Thanks for the additional information. We will inform you as soon as this issue is resolved.

Best regards,