We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Saving to PDF ignores line breaks in cell

Using the latest dll (4.8.2.15) and saving a sheet to pdf, I have some cells that are set to wrap text, and I have used Alt-Enter within those cells to force where the wrapping will take place. This used to work correctly, however with 4.8.2.15 it appears to ignore my forced line breaks when saving to pdf (workbook.save to FileFormatType.pdf). When printing or doing a print preview within Excel the cells correctly wrap where I've entered the Alt-Return.

Rick

Hi,

Could you post your template excel file and output pdf file here, we will check your issue soon.

Thank you.

Both files are in the zip.

Rick

Hi Rick,

Thanks for providing us the template files.

We found the issue after an initial test, we will figure it out soon.

Your issue has been logged into our issue tracking system with an issue id: CELLSNET-15670. We will inform you when it is sorted out.

Thank you.

I've attached another file showing the problem. I send out quite a few reports via pdf so this is causing some problems. Any idea on a timeframe or workaround?

Rick

Hi Rick,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for sharing the template file.

Yes, the issue does exist in your attached file too. We will update you soon regarding the ETA on a fix for this issue.

Thank you for understanding,

Hi,

Please try our latest version v4.9.0 (we released), we have fixed your issue:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry231670.aspx

Thank you.

I'm in the process of installing it, but have a question. I have Aspose Total, which includes cells. Aspose.Total creates a directory for cells named Aspose.Cells for .Net, however the standalone aspose.cells.msi wants to install to aspose.cells. First, can I simply install over the directory created by Aspose.Total?

Second, and more important, I can't install the new version. Running on Windows 7 64 bit, and when trying to install I get an error. The last message on the installer window is 'Starting IIS metabase transaction' and I then get a popup saying 'Cannot connect to Internet Information Server' with an error code of -2147221164.

Rick

Hi,

1) Well, the new Aspose.Cells.msi would install the component into Aspose/Aspose.Cells/ and not in Aspose/Aspose.Cells for .NET/ folder.

2) We will check your issue and get back to you soon.

Thank you.

Is there anyway to get just the updated dll's until we can resolve the install issue?

Rick

Hi,

Sure, you can get.

Please find attached the latest Aspose.Cells for .NET v4.9.0 (Aspose.Cells.dll) component here.


Thank you.

Hi,



2) Please re-download the installer Aspose.Cells for .NET v4.9.0: http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry231670.aspx

and try installing the product again. We have fixed a possible
installation issue for the machines having no IIS installed.



Please do let us know if you still find any installation issue now.



Thank you.

Thanks, installed with no problems!

Rick