We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Saving Word document to PDF - Chinese fonts are missing

Hi

I have been trawling through the forum but am not clear on how to resolve this.

We have documents authored MS Word 2003 and saved as Word 2003 XML format.

The document contains a mixture of roman and Chinese characters and displays correctly in MS Word. The Chinese characters are, apparently, available as part of the font ‘Times New Roman’.

We use ASPose.Words to save the document as a PDF using:

Dim loadOptions As New Aspose.Words.LoadOptions
loadOptions.LoadFormat = Aspose.Words.LoadFormat.Auto

Dim document As Aspose.Words.Document = New Aspose.Words.Document(inputFileLocation, loadOptions)

document.Save(outputFileLocation, Aspose.Words.SaveFormat.Pdf)

The resulting document does not display the Chinese characters - they just render as square blocks. There is a lot of information on this issue in the forums but appears to apply to much earlier versions of the product (we are using version 10.6) and it is not clear what the fix is. From what I have read on the forums, ASPose.Words should determine if the document Chinese characters, and if the font does not support it, will instead use ‘Arial Unicode MS Regular’. I can confirm that this font is installed on my PC.

Hi Steve,


Thanks for your inquiry. Could you please attach your input Word documents you’re getting problems with here for testing? I will investigate the issue on my side and provide you more information.

Best Regards,