We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Send method of Aspose.Email.Exchange.ExchangeClient returns (403) Forbidden

Hello Everyone,


Exchange Server 2003, Outlook 2003 and Aspose Version 2011.10.28


We are trying to send emails in our .Net application using Aspose.Email.Exchange.ExchangeClient. We are not having any issues instantiating our ExchangeClient object using the MailBoxURI, Username, Password and Domain but when it comes to invoking the "send" method, we receive the following error message:


The remote server returned an error: (403) Forbidden.


Anyone else experienced this and could shed some lights? We thought our issues were with our Exchange/Outlook security policies but we tried updating our securities using these steps but without success:


http://office.microsoft.com/en-us/office-2003-resource-kit/customizing-security-settings-by-using-the-outlook-security-template-HA001140293.aspx


As a test, we ran our application directly from the Exchange server, we increased all permissions in IIS for Exchange, and we increased the permissions in Exchange using System Manager.


We are out of ideas so any help would be greatly appreciated.


Thanks!

Hi,


Thank you for your inquiry.

In my initial test, I was unable to replicate the said problem by using the latest version of Aspose.Email for .NET v1.3.0. Please give the latest version a try and let us know of your feedback.

In case your problem persists then please try to arrange a test account for us. So we may investigate this matter with your problematic exchange server.

Thank you for the quick reply.


No luck with the latest dll :frowning:

We still receive (403) Forbidden. We noticed that the email gets placed in the “Draft” folder correctly (when opening Outlook as the admin user we are using to send the emails) but for some reason the email don’t go from the Draft folder to the “Sent Items” folder, therefore, they don’t get send properly.

It’s most likely an issue with our Exchange/Outlook settings so I will investigate in that path.

If anyone came across this and know what setting or policy needs to be set in Exchange/Outlook, please let me know.

Thank you very much!

Hi Sebastien,


Just curious if you are able to resolve your problem with ExchangeClient? If so then please share your solution for our knowledge.

Thanks and Regards,

Hello,


Unfortunately, I haven’t figured out my problem but my colleague was able to get it working on his development environment so we believe it is a permission or security issue with my development environment when connecting to Exchange.

We do not believe it’s an issue with Aspose at this point since he can get it working just fine with the same Exchange server and the same domain controller.

Thanks.