Server was unable to process request. --> Access is denied: 'Aspose.Pdf'


#1

Despite the tree entries I've found on this site on this topic, I realy tried anything to get it to work:

If I create a new visual studio ( test ) project and include the DLL: no problem: Project was created in:
C:\Documents and Settings\[USERNAME]\My Documents\Visual Studio Projects\Webproject1; Everything works fine

BUT

The main project is under Sourcecontrol with a working folder:
d:\work\[APPNAME]\WEB\ (Website = web project)
d:\work\[APPNAME]\BUSINESS\ (Business = webservice project)
d:\work\[APPNAME]\DATA\ (Data = Classfile)

I trie to get it working from the Data classes; (Add reference/Copy Local). But everytime I trie to get it working: Access is denied: 'Aspose.Pdf'.

The Aspose DLL is located in D:\Work\Binaries and is Copied Local into the project's bin folder.
Impersonalion = true.
The testwebsite and in the main website the same settings are used in IIS.

I am realy desperate looking for an answer: Which folder had to have what rights??

Please help.


#2

Hi,

Thank you for considering Aspose.

Sorry I'am not familiar with server setting. I will contact our web master to see if he can give some idea.


#3

Thank you for asking. The version we use is 2.7.1.0. Maybe I looked over it in the manuals?

The error occurres when i do the following: Pdf x = new Pdf();


#4

There is no content about this issue in the manuals. Searching the internet for similar problem and solution may help.


#5

I’ve done that,… but i can’t find whitch rights i have to set on what file of directory…


#6

I have spend now more than 12 hours trieing to get it to work. Including the licence file also doen't work..


#7

First please make sure the application has the reading right for the component and license file.


#8

Can you please be more precise? ASPNET user? Only Reading Rights? Now Everyone has full controll (Like all the othe DLL's in my project)


#9

I don't know which user is used in your application. Please check your Web.config file. You can try using another user like the following line:



#10

I use impersonation, I am “local admin”