We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

.SetLicense not working with a TOTAL product license key?

I’ve been using Aspose.Cells for a long time with an Aspose.Cells license only. Recently i’ve had a need for some Aspose.Words functionality in the same project… So i purchased an Aspose.Words.Total license key. I switched out the license files in my project, and am applying the SetLicense() method at basically App Startup (win32 app) in the same spot i was with the original Cells only license. The Cells code still works as epected, but the Words code is putting the “Evaluation Version” stuff all over my output files… I have the Words/Cells code mostly in an External Class, that is then a reference in my main winforms project, the main winforms project is where i have the license embedded/set - and i can verify it works because Cells acts as expected. I even tried putting the SetLicense in my GetDocx() custom method right before any words things were called/referenced, still no go. Thoughts?

Thanks

@dozierinc It seems you have applied the license only for Aspose.Cells. You should apply the license for both products in your code. Please see the code below:

// Apply Aspose.Words license.
Aspose.Words.License wordsLic = new Aspose.Words.License();
wordsLic.SetLicense("Aspose.Total.lic");

// Apply Aspose.Cells license.
Aspose.Cells.License cellsLic = new Aspose.Cells.License();
cellsLic.SetLicense("Aspose.Total.lic");