We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Setting Page Scaling when Printing a PDF

After generating a pdf and streaming it to the browser and opening it with acrobat. When I go to print the document under the Page Handling section of the print dialog box there is a drop down called Page Scaling. By default this seems to be set to "Shink to Printable Area". this is messing up my print out it is shrinking the image by a factor of 6%. Is there a way to set this in code to default it to none? I can not depend on the users to set this value evey time the print. I am adding an image that must be the correct size.

I search the forums and I found a simular post from 2006 that told the user they do not have that feature yet. I am guessing / hoping that after 2 plus years this feature has been added.

Thanks in advance

Hi,

Sorry for the delayed response.

I'm afraid, this feature is currently not supported, and we may not be able to support it in short time.

Regards,

shahzad.latif,
Thats the same answer you guys gave 3 years ago. Has this feature been added to a feature request list? If not can we get it added? How do I go about getting added?

Thanks
Blacknight

Dear Blacknight,

Can you please provide your PDF and let us check it? In my test the default setting is "none". Is your PDF created with Aspose.Pdf?

Tommy,
It is based on the printer you are printing to. I have 2 printer and both change the % of shinkage. but both shrink it a bit. I have tested this on 3 different computers and 2 differetn version of Acrobat reader. All of them default to Shink to Printable Area.

Hi,

We are working over this issue and will reply to you soon.

Hi,

I think you are right that it is based on the printer. I tested your PDF and the default setting is still "None" for my printer. I think this problem can't be resolved when generating PDF. If you want to print PDF with Aspose.Pdf.Kit, the default setting is "None" for page scaling.