We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Shadow behind shape is not visible when exporting to SVG

When saving a vsdm file as SVG, the shadow behind the shape in the Visio diagram is not visible in the SVG file. I’ve tried to attach 2 files to give an example of this (map page-1 is the relevant page) but the new system is not letting me do this.

Thanks,
Andrew

Hi Andrew,

Thank you for contacting support. It is because the new system does not allow attaching a file with the first post. You can attach files to any subsequent posts. We will fix this issue soon and sorry for the inconvenience caused.

Hi Andrew,

Thanks for contacting support.

Adding more to Imran’s comments, the problem related to file attachment is resolved. Now you can either attach files with your first post or with any subsequent post in the thread. Should you face any issue or you have any further query, please feel free to contact.

I’ve tried attaching a file to this thread but am still being told that “new users cannot upload attachments”

Andrew

Hi Andrew,

Thank you for the details. Please log-out from the Aspose site account, clear browser cache, and then re-login. You may also check on any other browser. Please let us know how that goes on your side. We are looking forward to helping you.

Thanks & Regards,
Imran Rafique

I’ve tried re-logging in and clearing the browser cache (in Chrome) and have tried a fresh login using IE11. It still won’t let me add an attachment to either a new post or an existing one.

Hi Andrew,

The issue has been fixed and you should be able to upload the files now. Please try again and let us know if you still see any issue. We are sorry for the inconvenience.

Best Regards,
Muhammad Ijaz

Triaster Sample.zip (116 KB)
The sample file is now attached.

Hi Andrew,

Thank you for sending a Zip file. We managed to replicate the problem of the missing shadow of shapes in the output SVG. It has been logged under the ticket ID DIAGRAMNET-51277 in our bug tracking system. We have linked your post to this ticket and will keep you informed regarding any available updates. We are sorry for the inconvenience caused.

Best Regards,
Imran Rafique

@andrew.ridgeley,
Thank you for being patient. The ticket ID DIAGRAMNET-51277 has been resolved. If there is no issue in the quality assurance phase, then this fix will be included in the next version 17.7 of Aspose.Diagram for .NET API. We will notify you as soon as the new release is published.

Best Regards,
Imran Rafique

@andrew.ridgeley,
Thank you for being patient. In reference to the ticket ID DIAGRAMNET-51277, please download and try the latest Hotfix version 17.6.1 of Aspose.Diagram for .NET API (download link: Aspose.Diagram for .NET 17.6.1) and let us know how that goes on your side.

Best Regards,
Imran Rafique

I can confirm that this issue is now fixed.

Thanks, Andrew

The issues you have found earlier (filed as DIAGRAMNET-51277) have been fixed in Aspose.Diagram for .NET 17.7. This message was posted using BugNotificationTool from Downloads module by imran.rafique